Arduino Nano BLE 33 - serial port down (Bootloop?)

Hi,
I'm trying to compile and upload a tf lite sketch(here ist the sketch). The first times I tried it, the sketch uploaded successfully but the serial port was unavailable. To get it to work again I had to unplug the Arduino and plug it in again, then I could reupload the sketch.
When I tried the same thing with another sketch, it worked as it should. After doing so several times and trying to debug the error, the Arduino stopped initializing the Serial port at all and I couldn't get a response from the Arduino.
So I ordered a new one, because I suspected that the Arduino broke due to some kind of physical issue, but the exact same thing happened to the second one(I Have tested it another computer).

So, how to proceed, how to debug something like this?

Greets from Germany!

The tricky thing about the boards with native USB functionality like the Nano 33 BLE is that the USB code that creates the CDC serial port is running on the same microcontroller as your sketch. This means your sketch code can break the USB code, or stop it from running.

Fortunately, there is an easy way to recover from this situation:

  • Press and release the reset button on your board quickly twice. You should now see the LED on the board pulsing, which means the bootloader is running. The double press causes the bootloader to run indefinitely (until the board is reset, powered off, or an upload is done), which means you don't need to get the timing of the reset just right.
  • Select the port of your board from the Tools > Port menu. The port will be different when the bootloader is running so don't assume you already have the correct port selected.
  • Start an upload in the Arduino IDE.

The upload should now finish successfully. After this, you should be able to go back to doing normal uploads without needing to press the reset button. If you still need to do the reset trick to do uploads after this, the problem may be caused by your code. You can verify this by uploading a simple sketch like File > Examples > 01.Basics > BareMinimum.

ok, thx for your instructions, I've got it to work again!

You're welcome. I'm glad to hear it's working now. Enjoy!
Per