Arduino Nano(CH340) suddenly disconnects from Computer/not connecting anymore

Hello Fellows,

I was running Code for some Neopixels WS2812B on my Nano, as suddenly the Nano cut the connection to my PC. The Neopixels freezed in their last state, so my Datapin didnt output anything. When I reconnect the Arduino to my PC, my PC does not recognize the Arduino anymore. But The PWR LED is turning on and the L LED is blinking very fast, but with a very low brightness. If I press the reset button on the Nano, the L LED stops blinking, but after I relase it it is contiuing with the blinking.
When I power up the Arduino with an external 5V power supply it seems to work fine. It runs the last Sketch and I could even program the Arduino with the external 5V power supply connected to +5V and mini usb both plugged it.

Can someone help me to fix the Nano so that I can program and use it again with only the USB-Mini cable plugged in to it?

When only the USB cable is plugged in the USB-Diode measures a Voltage of 1.9V(if that helps).

Thank you for your time


Try another USB cable. Especially the cheap Chinese ones are notoriously unreliable.

Already tried. It worked before hand aswell. My other Nanos work fine with the cable, so did the broken one, well until it broke

How were you powering the LED's ?
If it was directly from the NANO you may well have overloaded it and caused some damage.

But at $2.00 each for the clones it is not a big loss.


I used an external 5V 4A Power supply and used 64LEDs. I just connected the Datapin via 2 220 Ohm Resistors to the Data-in of the LEDs and connected the ground of the Nano with the ground of the external 5v power supply.

Even if I would have to use a new Nano, I would like to get solve the issue!

If you did any soldering on or near the board or any connections while the board had power you may want to check carefully for burnt out parts or solder splashes / whiskers etc.
A split second mistake can easily let the magic smoke out of electronics with zero chance of getting the darned stuff back in.

We cannot see how it was wired up and used so we rely on you to provide the best information.

BTW did you have a COMMON GROUND back to the NANO ?
You should have one as that too can cause miscellaneous errors.


I did use a common Ground and I couldnt find any burned parts. It still runs its sketch when I power it via an external power supply on the +5V pin. But powering it via only the mini USB seems to fail. If I just connect the Nano to my PC via USB my PC does not recognize it. But if I plug in the usb AND a power supply at the same time, my pc recoginzes the board. So there has to be something wrong with the usb. Thats why i posted the Voltage i measured on the usb-diode on the backside of the board


Somehow its sounds like you managed to burn out a regulator.
How that happened only you would be able to tell i am afraid.

Normally a power rail was abused in some way.


I dont know either. No puff, no weird smell and the board doesnt look damaged. I will still use the board for debugging and stuff, but for the longterm project use one that is not damaged.

Still thank you all for trying to solve this issue!

If someone finds a solution feel free to post it here!