Arduino Nano (Clone): Programmer reagiert nicht

Hallo,

ich habe bisher erste Schritte mit einem Arduino UNO gemacht.
Unter Linux Mint 18.2 und der Arduino IDE hatte ich keinerlei Probleme beim "hochladen" meiner Programme auf den Arduinos.

Nun habe ich Heute einen Arduino Nano, bzw. vermutich einen Clone erhalten.
http://www.ebay.de/itm/Nano-V3-Modul-Atmel-MEGA328P-Board-CH340G-kompatibel-mit-Arduino/182787369951?ssPageName=STRK%3AMEBIDX%3AIT&_trksid=p2057872.m2749.l2649

Nano v3
Atmel MEGA328P
CH340G
... lauten die technischen Daten.

Per USB wird er auch auf /dev/ttyUSB0 erkannt.
Als Board habe ich Arduino Nano ausgewählt und als Prozessor Atmel MEGA328P
Der Programmer steht noch vom UNO auf AVRISP mkII

Wenn ich versuche ein Programm hochzuladen erhalte ich eine Fehlermeldung:

avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x00

Das Ganze wird dann 10x versucht und dann wird abgebrochen.

Kann mir Jemand so aus dem Ärmel sagen, was ich falsch mache?

Danke Cappy

Die Klone nutzen einen anderen USB-seriell Wandler als die original Nanos ( eben den erwähnten CH340 ). Deshalb brauchst Du dafür einen eigenen Treiber, den bringt die Arduino IDE nicht mit.
Einfach mal nach 'CH340 Treiber' googeln.

Wenn Du den Nano ansteckst, blinken da irgendwelche LEDs, oder leuchtet nur die BetriebsLED?

... nur die Betriebs-LED.
Soweit ich weiß ist unter LINUX kein Treiber nötig, oder?

Cappy

... nur die Betriebs-LED.

-->Und wenn Du den Reset-Taster betätigst, auch kein kurzes Blinken?

Bei Linux ist der Treiber für den CH340 dabei.

... nur die Betriebs-LED.

Wenn es sich um einen Fabrikneuen Nano mit Booloader handelt, muß die Led im Sekundentakt blinken, sonst ist kein Bootloader drauf. Wie versuchst du das Hochladen des Programms?

Das ist ein Clon. Es gibt keinen orginal-Arduino mit dem CH340.

Genau, nimm dir deinen UNO, und brenne damit einen Bootloader auf den Nanno.
Wenn das nicht klappt reklamieren.

Moin,

wenn ich mich recht erinnere, hat der "Nano" geblinkt, als ich ihn das erste mal an den USB angeschlossen habe.
Dann habe ich das erste Programm hochgeladen und es passierte nix.

Wenn ich den RESET drücke, passiert nix.

Übrigens hat auch niemand behauptet, dass es ein original Arduino wäre.

combie:
Genau, nimm dir deinen UNO, und brenne damit einen Bootloader auf den Nanno.
Wenn das nicht klappt reklamieren.

Ja ... coole Idee ... verätst Du auch wie?

Cappy

cappy0815:
Übrigens hat auch niemand behauptet, dass es ein original Arduino wäre.

Doch, Du in der Überschrift : "Arduino Nano: Programmer reagiert nicht " Nichr orginale Arduinos dürfen den Namen nicht verwenden. Wenn Du ihn verwendest nehme ich mal an daß es ein orginaler ist.

Ja ... coole Idee ... verätst Du auch wie?

Grüße Uwe

... oh Mann ... das grenzt aber schon an "Klugscheisserei", oder?
Aber okay ... dann nehme ich es zurück und behaupte das Gegenteil.

Danke für den Link

Du magst auch Deine Rechte gewahrt wissen oder?
Aber in einem Land mit dem Rechtsmittel Abmahnung würd'ich schon aufpassen.
Grüße Uwe

Keine Klugscheisserei. Uwe moderiert das Forum, welches von der Firma finanziert wird, die den Arduino als open source entwickelt hat und eben auch eigene Hardware verkauft, unter der Marke Arduino. Da darf man ihm ruhig zugestehen, auf den Unterschied hinzuweisen.
Manchmal gibt es aber auch wirklich deutliche Unterschiede zwischen den Originalen, den legalen Nachbauten und den Klonen. So wie bei dir mit dem ch340 Chip. Da ist es natürlich wichtig zu wissen, dass es eben KEIN Arduino ist.

uwefed:
Du magst auch Deine Rechte gewahrt wissen oder?
Aber in einem Land mit dem Rechtsmittel Abmahnung würd'ich schon aufpassen.
Grüße Uwe

Sowas gibt es nur in Deutschland. Da haben die Rechtsanwälte eine gute Lobby. Bei uns bekommst du ggf. auch Post vom Anwalt, dass du das sein lassen sollst. Aber weder Kostennote noch sonst was.