Arduino Nano clone - Unknown USB Device (Device Descriptor Request Failed) (code 43)

I have bought Arduino Nano clones and Arduino Mega clones for a project recently. All the Arduino Mega clones work like they are supposed to, but none of my new Arduino Nano clones are recognized by the USB. In my device manager, it says "Unknown USB Device (Device Descriptor Request Failed)". In the properties, it specifies "Code 43".

The thing is, I already had the CH340 drivers installed from using my old Arduino Uno clone and ESP8266 board but nevertheless, I uninstalled and re-installed the drivers. No change. When I tried to upload the driver in the device manager window, it said that the best driver is already installed.

Nothing was connected to my boards when I connected them to my PC and since they are brand new, there shouldn't be any sketch loaded in it. I had no such problems using Arduino Uno clone in the past and my new Arduino Mega clones also work. The same problem persists when I switch the USB ports or use a different computer - Arduino Mega clones work, while Arduino Nano clones aren't recognized.

Is there a problem with Arduino Nano clones that requires a different solution or would this mean the boards themselves are faulty? If so, how do I fix it? It seems unlikely that all four of my new Arduino Nano clones would be faulty, but I don't know how else to explain this.

A picture is worth a thousand words.
Take a good focused picture of either side of the board and post them back here.
It could be that they are CP2102 or FT232 chips which may require additional drivers.


Here is the picture of the bottom side, where the chip should be. I can't tell what is/was written on it, though.

It does look a lot like a CH340.
Have you contacted the seller to find out which chip it uses or do you have the link ?

Also have you checked the soldering in case there is a fault on the pins.
That can also be an issue with some boards.
Maybe a pic of the other side may help too ?

The seller specified that it's CH340 and linked to the site where I downloaded the driver from. The Mega clones that work just fine also have CH340 chip.![IMG_20211027_160224|375x500]
Edit: Here's that other picture, the pins look okay to me and I also tried connecting with different USB cables.

If it does not blink the LED when powered up from USB then I suspect that they may be faulty in some manner.

It's powered down even after the device is connected so I'll probably have to contact the company about it. Thank you for the advice!

Can you see the VID and PID identifiers in device manager? These can usually be found - even with 'unknown devices' - under properties->details. ( I don't have an english version of windows so I don't know exactly where to find )
VID and PID ( Vendor-ID and product ID ) identify the USB chip and windows uses these to know which driver to use.
This page can be used to identify a chip by its VID and PID. The example entries in the link are for a CH340

1 Like