Arduino nano do not upload

I've recently bought an Arduino Nano original, but I can't upload any program.
I've already checked troubleshotting and
-the problem is not my pc beacause i tried also in another pc
-I've tried different cables
-I've tried to upload without anything connected and with default program
-I've selected right board an COM
It gave me different errors like
-avrdude: ser_open(): can't open device "\.\COM6": Access is denied.
-avrdude: stk500_recv(): programmer is not responding
Thank you for helping

I had this problem: have you tried selecting "old bootloader" option under Tools, Processor?

Access is denied means you have another program with the port open. Close that program or tell it to disconnect (maybe a serial monitor open from doing the loopback test, in another instance of the IDE)

The other error can indicate a huge number of things ("avrdude: stk500_recv(): programmer is not responding" is the last error posted when it's able to open the serial port, but not talk to the device you're trying to upload to). If you are using a nano with the new bootloader on a version of the IDE (AVR board package 1.6.21 or earlier) that doesn't support it, or a version that does but with old bootloader selected, or using a nano with the old bootloader with the non-old-bootloader option selected, you will get 10 sync errors, followed by that error.

Official boards produced after feb. 2018 use the new bootloader - but there are still resellers with stock that has the old bootloader.

Older official boards, and all clone boards, use the old bootloader.

If the IDE does not show and "old bootloader" option under tools -> processor, it predates the new bootloader, and must be updated to do so.

(yes, this bootloader upgrade has been a total mess. Worse still, with a simple change, they could have also gotten an extra 1.5k of program space on the nano. Or with another even simpler change, they could have made the two totally compatible, and just fixed the one bug they set out to fix)