Arduino Nano Freezes on Battery Power - Not on USB

Hey Guys -

I’m (hopefully) wrapping up a project soon, but after assembly discovered an issue. My project has a good number of components (Fritzing attached) and when plugged in via USB everything works flawlessly. Unfortunately, when powered via external battery; it starts to work then freezes after a few seconds.

Everything is wired to share the same 5V source, so when powered via USB, all parts get their power from Arduino. When powered via battery, its from a 3.7V → PowerBoost 500 which yields in 5.2V. Both supply 500mA, so not sure what issue is.

What I’ve Tried (without change in result)

  • Wiring source power to 5V instead of VIN on Arduino

  • Adding 1000u capacitor in between power source & Arduino

Note: Realize there are many LEDs but only one pair light up at once - although pattern they move in may make them flash sequentially really fast.

Any suggestions?

Do you have a schematic? Fritzings are not schematics. They might be colorful, but they do not show all needed information. Schematics are the language for electronics hardware.

Please also provide links to non-Arduino components datasheets and post your code.

1 Like

When connected to USB, you are not using the onboard voltage regulator. The +5V coming from the USB it tied to the output of the voltage regulator (+5V on the board) so I bet it can supply much more than the 500mA that the onboard voltage regulator can supply.
Also, when on the battery, you want that tied to +5V on the board, not Vin. Vin needs to be at least 6V as the input to the voltage regulator. The +5V pin is on the output side

1 Like

The Fritzing is just fine. You have simply applied your 5v to the wrong pin - VIN instead of 5v. As I understand it, VIN is badly named. It is actually an output pin that supplies the power came IN at the barrel jack to another shield that has its own regulators, e.g an Ethernet shield. I am guessing that the 18650 is up to the job.

I guess the battery or the boost converter or the 5volt regulator of the Nano is not up to the job of supplying the stall current of the (unspecified) servo. Even a tiny servo like an SG-90 could draw ~650mA peaks, which USB supply might be able to provide until you trip the protection of the PC or burn out the USB port.

Did you try without the servo?
Leo…

Thanks Guys -

As mentioned initially, i did try wiring the power to the 5V as well as VIN but got the same results. I’ll try it without the servo as it can be activated frequently. What I don’t get is that I was under the impression that a computer’s USB port (2.0) had a max offering of 500mA - the same amount supplied when on battery power. if true, why isn’t it working?

Happy to test without servo, but if it is due to servo; how to resolve? I tried a capacitor in between source & Arduino without improvement - should it be elsewhere or should I just route the battery power to (only) the Arduino’s USB port?

Thanks

A) No, Fritzing is NOT fine, it tells us nothing. Without a proper circuit diagram, few of us will be able to assist.

B) Vin is correctly named. It is intended to power the board from an external supply and maybe an LED or two. It is not designed for and will not tolerate any other power being pulled from it. The regulator is a tiny SMD component with no heatsink and so it gets hot and shuts down if you abuse it.

All 5V devices including the board should be fed from an external 5V supply, capable of the current required by everything, plus some headroom.

[quote=“bzowk, post:6, topic:851473”]
that a computer’s USB port (2.0) had a max offering of 500mA -
[/quote]I think that is just a nominal figure and not to be relied on. It may even be OK delivering more than one might expect. This means that your weak link is likely to be that Powerboost 500mA. It is pretty mean at best and from what Wawa says, likely to be a mistake. There can also be a lot of lying and loose language when it comes to painting numbers on 18650s as well, hence my comment. Cheap Ebay ones deliver what you pay for and good ones can be quite expensive. I guess taking the servo out of play will reveal all

Hi,

Did you disconnect from Vin before connecting to 5V?

Do you have a DMM?

Can you please post a picture of your project so we can see your component layout?

Thanks… Tom… :grinning: :+1: :coffee: :australia:

Morning, Guys -

So disconnected the servo and still froze, so instead replaced the PowerBoost 500 with a MT3608 Step-Up Adjustable DC-DC Switching Boost Converter which I tuned to 5.2V. It worked! Assume PowerBoost may have had been delivering far less than 500mA.

Thanks for your help and suggestions!

1 Like

Hi,
Thanks for coming back and letting us know the solution.

Tom… :grinning: :+1: :coffee: :australia:

Good. Supply on the +5v pin ?!?..

Yeah - Left it there instead of VIN simply because it was the last one I tried during a prior test.

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.