Arduino Nano - No power when connected

Problem: My Arduino Nano is not getting any power when I connect it to my USB port. None of the LEDs are on. When I use a USB-to-Serial cable however, it does receive power. But it's not ideal for little test projects where i use the Nano as the power source (through the USB).

This has happened twice already. At first, I thought it was just a cable issue but I tried 3 other USB cables and still no effect. I bought a new Nano thinking that maybe it has something to do with the first one. The second worked at first, and then when I disconnected it to setup for another project and re-connected later on, the problem came up again.

I'm not sure at all where to go from here. I've searched online but haven't found too many people with my problem. The very few who did had an issue with a burnt diode, but the models I'm using don't have that.

Any help or advice would be appreciated. Thanks

Looks like something in your setup is damaging the boards. Could you post your circuit so that we could take a look? I'd also check that the USB voltage provided from your PC is in spec.

"When I use a USB-to-Serial cable however, it does receive power"

I don't know how that cable hooks up. Can you explain please?

Have you been running any unusually heavy power loads off the nano?