Arduino nano not working help

I am trying to connect my Arduino nano to my computer, but whenever I try to upload anything it says "Error uploading, check if the selected board is currently available." Can anyone help? (and yes, I do have the agent installed)

Hi @electric_panda. In order to gather more information that might help us to troubleshoot your problem, I'm going to ask you to post the full output from the upload when in verbose mode.

Please do this:

  1. Attempt an upload.
  2. Wait for the upload to fail.
  3. Hover the mouse over the red bar at the bottom of the Arduino Web Editor that shows the error message. Click and drag it up so you can see the black console window.
  4. Click the icon in the top right corner of the console that looks like two pieces of paper.
  5. In a forum reply here, click on the reply field.
  6. Click the </> icon on the post composer toolbar. This will add the forum's code block markup (```) to your reply to make sure the error messages are correctly formatted.
    Code block
  7. Press Ctrl+V. This will paste the error output from the upload into the code block.
  8. Move the cursor outside of the code tags before you add any additional text to your reply.
  9. Click the Reply button to post the output.

Hi, @electric_panda
Welcome to the forum.

Please read the post at the start of any forum , entitled "How to use this Forum".

This will help with advice on how to present your code and problems.

Is this the first Arduino controller you have tried to upload to?
Have you selected the correct board and also tried the Old Bootloader option.

Tom.. :smiley: :+1: :coffee: :australia: