Arduino Nano Not Working on External Power


I have looked on various different threads that seem to have the same problem but it sounds like everyone is having slightly different issues then me because none of their solutions worked. (See below for threads I tried).

I am trying to power an Arduino Nano on external power (5.2V). When I had the Nano plugged into the USB port on the computer, it ran as expected (the Nano is powering an LCD screen) and the desired message showed up on the screen. However, when I plugged the Arduino into a 5.2 V power source from a battery, the screen lit up white and the Arduino power LED turned red, but the program written on the Arduino did not run and display on the screen.

Ultimately I am worried that my battery supply is insufficient. With the circuit I have set up, I need to power the Arduino with 3.3-5.2V. The LCD board can be supplied with 3.3V. Is this possible? I tried a setup where the Arduino was powered with the 5V pin and also output to the LCD screen with the 5V pin, but it did not result in the screen displaying the message - just the usual white screen. Any ideas on how to resolve this issue? Thanks in advance!