Arduino Nano TX/RX problem

Hi gang.

I am trying to connect an Arduino Nano to an Orion/Merlin head.

Because the connection is half-duplex I am connecting the Arduino TX/RX with 2x 220 ohm resistors to communicate, like this.

Arduino Port D0 tx <—> [220 ohm]
}<—> Orion/Merlin data port.
Arduino Port D1 rx <—> [220 ohm]

I always get an error when trying to upload a sketch to the Arduino Nano.

Binary sketch size: 4250 bytes (of a 14336 byte maximum)

avrdude: stk500_getsync(): not in sync: resp=0x30
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

Now I just tried disconnecting everything except leaving the 2 Resistors in the D0 and D1 port with joint ends on the other side, there to say not connected to the Merlin at all. and I still get this error when trying to upload, disconnect the 2 resistors and everything is fine.

It does not what kind of Sketch I try to upload it tries and then brings this error up.

This guy was using one, I guess an older version of Arduino and it seemed to work for him.

http://www.gigapixel.nu/info_project.php

Any ideas?

Yes the resistors are interfering with the serial communications. It is best to include a double pole switch to isolate any serial device when you are uploading sketches. Just like I did in this project:- http://www.thebox.myzen.co.uk/Hardware/MIDI_Shield.html

So it is still fine to connect the TX/RX together using 2 resistors and joining them on the outside end, the only problem will come up when a sketch is being uploaded to the board, having an on/off switch will take care of that.

Ok great I will keep that in mind.