Arduino Nano uploading problems

Hi everyone,

I'm fairly new to all this and am making a simple MicroSD datalogger based on a Nano.

I'm using an SD tester code found on these forums, written by Limor Fried and Tom Igoe.

I used this earlier in the year with a Nano 'clone' - initially it was working, but I tried the same circuit again a few days ago to no avail.

Thinking that the issue was with the fact I hadn't used a genuine Nano, off I went to RS components to get myself a genuine one.
All went well on the first day, and I managed to get one of my own codes written too, which shows the presence of the SD with an LED on Digital Pin 2. This worked yesterday too.

For continuity, I'm using the same port (COM6) and the same programming interface cable.

However, today I can't get it to work. Trying to revert back to a simple code to minimise issues, I got the message 'problem uploading to board'

Take the shield off and it will work again - but for some reason if I upload the same code as I had before, it doesn't work. The serial monitor can't seem to communicate with the board either.

I have posted this on this section of the forum as I believe that it is not related to my board or to the code - both of these worked before.

Sorry for the 'story telling', just wanted to present all of the relevant info.

So my question is - can the board be programmed with a shield attached?
Also, any ideas why I can't establish serial comms any more?

Thanks everyone!

Please do this:

  • File > Preferences > Show verbose output during: > compilation (uncheck) > upload (check) > OK
  • Sketch > Upload
  • After the upload fails you’ll see a button on the right side of the orange bar “Copy error messages”. Click that button.
  • Paste the error messages in a reply here USING CODE TAGS (</> button on the forum toolbar).