Arduino Nano v3 I2C crazyness

Hi all,

I'm using a Nano v3 and a 2 line LCD screen (from DfRobots). It was previously working fine with i2c address 0x27 as specified on the back panel. I don't know if this is related to version 1.0.5 of the Arduino software, but I'm not able to use I2C (so the wire ant TWI) interface anymore.

I'm using ports A4 (SDA) and A5 (SCL) of the nano to wire to the LCD screen. When running a simple i2c scanner code (Wire.begin() then Wire.beginTransmission(address) for every possible address), I find nothing. I tried to hook another i2c chip I have, a MCP23018(http://ww1.microchip.com/downloads/en/DeviceDoc/22103a.pdf). When trying this, the program just stop in the middle of the run...

As everything was working fine previously and as I'm trying with two different nano, I expect the problem to be software related...

Have you tried Nick Gammon's scanner? http://www.gammon.com.au/forum/?id=10896&reply=6#reply6

If that doesn't find anything, double check the wiring.

Pete

Yes, I used a scanner and as I said, nothing is found, will it be with the LCD screen or another I2C chip that used to work few months ago (and before I switched to the new Arduino release)

Anyone with a Nano could have a try with a I2C device ?

Pull up resistors?

MarkT: Pull up resistors?

Never found that to be a problem.

You sure you did not swap SDA and SCL somehow?