Arduino Nano Vin does not work with more than 5v


I have a strange issue with a chinese Arduino Nano board. Is it possible that it is a defective board or am I missing something?

  1. Connected with USB and uploaded blink sample --> power led on, led 13 blinks OK
  2. Connected universal ac dc adapter set to 12v --> power led on, led 13 won't blink
  3. Connected universal ac dc adapter set to 9v --> power led on, led 13 won't blink
  4. Connected universal ac dc adapter set to 6v --> power led on, led 13 won't blink
  5. Connected universal ac dc adapter set to 5v --> power led on, led 13 blinks OK

For 2, 3, 4 and 5 I have connected the power supply to Vin and Gnd pins directly.

I am guessing it is a defective board since Nano specs says that Vin can take 6-20v (limits). Am I right?

ps.: I want to feed my Arduino with 12v power supply because I need to power 2 fans with 12v. Arduino will control these fans through PWM and transistor. When PWM is at 255 the transistor will allow 12v to flow from power supply to the fans (max speed). This works fine with Arduino regular board (the big one).

Yep, sounds like a defective board or they skimped on some of the parts... Compare your board with the image here and see if they are the same.

From your observations I'd say that it's the AC adapter at fault. Cheap multi-voltage adapters never give out what it says on the box: How do you explain that it works on the 5v setting, when the minimum required on V-in is 6v? Get a regulated 5v supply!

Thanks guys!

  1. I'll get a new Arduino Nano delivered sometime this week and will check with this new unit, I'll let you know the results.

  2. I have checked the power supply and it is giving me 12.something volts without load, I think it is ok since the limit is 20v. Must be the chinese cheap parts.

Now, what if this issue cannot be solved, what should I do? Should I build my own regulator (more reliable) and feed the Arduino board using the 5v pin?

I have read a little about this and it seems I just need a regulator + some capacitors to make it work. Any advice from you guys? I have a lots of experience in software but I have not much knowledge of electronics.


Try using a 9v battery (or anything 6 to 12v); if that works then the AC adapter is at fault, if it doesn't then replace the board.

You could also try putting a big capacitor across power and ground of the AC adapter. It's odd that the power LED is lit at all voltages, but with some the sketch doesn't run - that would suggest a noisy supply which is resetting the chip.

Martin-X I have tried the 9v battery but no luck.

The new Arduino Nano board worked fine in all voltages up to 12v! I guess the old one came with problem or I did manage to break it somehow.

Thanks for your help guys!