Arduino ne redemarre pas apres mis en veille

Bonjour

Je viens vers vous car apres avoir cherché un peu de partout, je ne trouve pas de solution. J'ai un ambilight qui fonctionne avec arduino (teensy 2++) et processing. voici mon probleme:

  • Je téléverse le programme arduino dans la teensy puis je lance mon programme processing, mon bandeau s'elaire aucun probleme. J'arrete tout et je passe mon pc en veille.
    -Quelques temps plus tard je sors de veille le pc et relance mon programme processing (en théorie le programme arduino est toujours dans la teensy) et la, le bandeau ne s'eclaire pas. Je suis obligé de téléverser a nouveau le programme arduino dans la Teensy en rebootant celle ci car déjà occupé par le meme programme.

Arduino reconnait pourtant bien ma Teensy en COM3.

Par contre si au lieu de passer en veille le pc je l'arrete puis quelques temps apres je le rallume, le programme arduino est détécté automatiquement et se lance.

Avez vous une idée sur ce probleme?

Merci pour les futures réponses

bonjour,
pourquoi téléverser de nouveau le sketch?
il est déjà en place.
ca vient à mon avis du fait que l'usb est mis en veille aussi.
il coupe la connexion usb par la mise en veille par économie.
vire la mise en veille de l'usb dans l'admin config du pc.

entre nous, mieux vaut arrêter le pc que de le mettre en veille, c'est une source de problème.

Je suis obligé de téléverser a nouveau le programme arduino dans la Teensy

Je pense qu'une simple déconnexion/reconnexion de la teensy ferait la même chose.
A la sortie de veille la carte ne doit pas être reconnue comme un périphérique et le port COM ne doit pas être remonté automatiquement.

MisterT2000:
Par contre si au lieu de passer en veille le pc je l'arrete puis quelques temps apres je le rallume, le programme arduino est détécté automatiquement et se lance.

Avez vous une idée sur ce probleme?

Merci pour les futures réponses

Mauvais plan la mise en veille PC
chacun crois garder ses petits au chaud :grin:
et au reveil si tu les vois toujours, ils ne t'entendent/ecoutent plus

infobarquee:
entre nous, mieux vaut arrêter le pc que de le mettre en veille, c'est une source de problème.

Ca c'est parce que t'es encore sous Windows 3.1 xD

Perso j'ai pas arrêté mes PC depuis des lustres ... Et aucun soucis :wink:

Bonjour et merci pour ces réponses.
Il me semble avoir deja essayé de desactiver la veille des ports USB dans le gestionnaire de peripheriques (windows 7) et cela n’avait pas donné de resultat
Je vais de nouveau réessayé. je vous tiens informé de la suite des évenements

Sinon si vous avez d’autres idées je suis preneur

Merci a tous

Je viens vous faire part de la suite des evenements. J'ai basculé tous les ports USB de manière a ne pas les desactiver lors de la mise en veille du PC et je n'ai pas de changement. apres chaque sortie de veille, je suis obligé de rebooter la teensy (pourtant en ouvrant teensy loader, le programme est bien present)
Avez vous d'autres idées?

Merci pour les futures réponses

lu sur un autre forum, jamais testé

  1. Clique sur Démarrer ,
    clique sur Exécuter ,
    tape msconfig .

  2. Cliquez sur Avancé , désactivez la case à cocher Activer DeepSleep