Arduino Network causing severe battery drain on WiFi connected devices.

So I have a weather station that uploads weather data to COSM every 10 seconds. This works fine.

However, I noticed that when my Weather Station is running, the battery life on all of the mobile devices that are connected to the network via WiFi (i.e. several mobile phones, couple of tablets, various brands/types) is terrible. To put this difference in perspective, with the Weather Station on, the battery life on my phone is about 4 hours. With the Weather Station off it's 2 days. This is repeatable every time.

I can see from some diagnostics on my phone that 98% of the battery use is due to WiFi RX Wakelocks. In other words, it's receiving stuff on WiFi and having to wake up deal with it.

Wireshark tells us what the problem is. Every time the Weather Station uploads its data to the internet it sends an ARP broadcast:

ARP Who has 192.168.0.1? Tell 192.168.0.20

192.168.0.20 is the IP of the Weather Station, and 192.168.0.1 is the gateway.

So what it's doing is trying to get the MAC address for the router from its IP address so that it can communicate with it. This is absolutely normal... ONCE (it should store the MAC address in its ARP table), but it does this every time it tries to connect. The rest of my devices only send such ARP broadcasts once after a reboot.

Does anybody have any suggestions on how to fix or work around this?

What kind of Arduino Wifi hardware are you using?

Interesting. I see the same thing happening with my arduino ethernet: every time it wants to talk to its target web server, there is an ARP request. Mind you, there's a bunch more ARP requests going on that don't make sense either - some of them generated by the router, and my Mac and XP box seemingly can't remember each others MAC address. I suspect that the same thing is going on with my wifi shield too but I can't see that traffic with wireshark.

Put a cheap router between them and have two subnets (such as 198.168.0.* and 198.168.1.*), or if your gear is capable, change the routing in it to implement this. The ARPs will not find their way off the arduino's subnet to the other one where your phones and tablets are connected.

I'll hedge a bit and say I'm pretty sure that will solve the problem, but not 100%. ARP is OSI L1 and therefore does not pass through the router.

Thanks for the replies so far. To answer everyone...

I'm using an Arduino Ethernet, not a WiFi one: http://arduino.cc/en/Main/ArduinoBoardEthernet

I tried putting it on another subnet (192.168.1.20 as opposed to 192.168.0.20), but the requests still appear on every device on the LAN. I'm guessing this is because they're sent to a MAC of FF:FF:FF:FF:FF:FF. I didn't try putting another router between the device as I don't have a spare. Really though, I don't want yet another device plugged in with even more cabling, when this seems like a an issue that could be fixed in the library or code.

It's not the subnet that holds back the ARPs, it a different segment, so you need a router between the two segments. Depending on the router you're using for your WLAN you may have the possibility to separate the WLAN and LAN part of your network. For example if you're using OpenWRT on your WLAN router, this is possible.

Thanks for the clarification - much appreciated. I was sort of naively hoping that putting it on another subnet would be enough as some broadcasts I see on Wire Shark are sent to 192.168.0.255 and I also hoped the router would segment the subnets itself given everything on the other subnet is all coming off one port on the router.

If this can't be fixed in the Ethernet code (or mine), then I'll look at getting an additional router. The one I have doesn't have an OpenWRT port (yet).

I'm hoping that when I have time to trawl through the network libraries I'll be able to find a place where I can add entries to an ARP table.

ARP isn't done on the Arduino processor but by the WizNet5100 itself, so you cannot change the Ethernet library to work around that.

Have you checked your routers configuration if there isn't an option to separate the wireless from the fixed network? Some of the routers (even without an Open Source firmware) offer such an option.

I'll not check the Ethernet library then :) Thanks for saving me a lot of time there.

It's a shame there's no function to add an IP address with its MAC too so it never has to try and get that info from the network. Obviously on Windows or Linux you can manually add a static ARP entry with the arp command.

On my router I can "isolate" any of its WiFi networks, which means all devices using that SSID have no access to the LAN and can only access the internet. This does work and would be a good solution but I need to access my LAN from wireless devices (e.g. VNC/Remote Desktop from my phone to PC).

Unless there's some undocumented arp command, it looks like I'll need a cheap router. There's another device that is (optionally) connected to my network that does this every second (another embedded system) so that sweetens the situation a bit.

Just because I am curious (and use a lot of routers) what make/model router do you have now?

Asus RT-N66U

The Arduino gets its revenge on all those devices with the fancy power saving. Denial of service by battery depletion. Not a novel attack, but possibly a novel vector.

-br

I downloaded that router manual, just because I haven't used it before, but it seems fairly easy to set up. It appears by the manual the wireless network will use 192.168.1.1/24.

edit: I do not see any ethernet LAN ports on that box.

You sure you got the right manual? Check here: http://www.asus.com/Networking/RTN66U/

As you can see from the description it has 4 gbit LAN and 1 gbit WAN (which you can also use as a normal LAN port if you're using the router in just Access Point mode).

The RT-N66U is an awesome little router. Just this morning I was telnetted into its Linux shell and reading of the temperatures from three temperature sensors on the board. It's a geek-boy's dream ;)

Forgot to say... I'm not sure where those IP ranges are coming from. There is only one place to set the IP and MASK that the router will use. It uses the same for both LAN and WLAN. Even in the DHCP settings it won't let you set IPs out of the range of that single IP + Mask.

My bad. I downloaded the wrong manual. I have the correct one now. I would go into the router settings and check your LAN settings. What ip/subnet does it show? It should be 192.168.1.1.

I would also check the dhcp server settings for your LAN. Avoid using any (add: static) ips in that range.

edit: Try dhcp on the ethernet shield. Does it pick up an ip?

I’m using 192.168.0.0/24 (but that’s OK obviously). DHCP is off (I prefer static IPs). There’s no way to specify independent IP ranges for the LAN and WLAN in the settings.

However, this isn’t a WLAN / LAN / IP / Subnet type issue - it’s an ARP Broadcast issue. It wouldn’t matter what IP or subnet I was using because the broadcasts are sent to FF:FF:FF:FF:FF:FF, so they hit every device on the same network segment. As I only have one router the entire LAN/WLAN is the same segment. The only thing my router is blocking broadcasts from/to is the WAN.

The only way to prevent broadcasts spreading too far is to add a segment to the network by adding another router as routers don’t normally allow broadcasts to pass through. I could, for example, add another WiFi Access Point router and put all my mobile devices on that. But again that’s additional hardware that I’d like to avoid.

That is odd. I haven't checked my network for that. When I get a chance, I will. Mine might be doing that, but I do not see any noticeable indication yet.

edit: I probably wouldn't see anything on my wireless network. My wireless and ethernet are separate networks, so I wouldn't see the effect on my mobile devices.

You can see broadcasts on Wireshark if you want to look for it. Just download it, install it, run it, and set a filter for “eth.dst == ff:ff:ff:ff:ff:ff”.

It’s normal for every device on the network to send out the ARP "Who has " requests the first time they try to communicate with that IP. It’s a bit like the way DNS works, in that when you enter “google.com” as an address, a DNS server will look up that IP address for that domain name and you’ll use the IP address. A MAC is looked up by IP address by asking every device on the network "Who has ". The device that has that IP will respond with its MAC address and then the two devices can then communicate.

For example, if you reboot your PC, the first time it tries to connect to the internet it will send out a “Who has 192.168.1.1” broadcast (assuming 192.168.1.1 is your gateway’s IP and you have that IP set as the default gateway on your PC). Whichever device has that IP address will respond back with its MAC address. Then your PC will know what MAC address to send stuff to when communicating with your gateway.

What is meant to happen, however, is that the MAC address for a given IP address is meant to be stored in the device’s ARP table. You can see the ARP table on Windows by opening a command prompt and doing “arp -a”. This table prevents the need to ask all the devices on your network who has a given IP address every time you want to talk to that IP because the device already knows that information and has remembered it. You can also add MAC addresses manually and permanently (until you manually delete them) with something like “arp -s 192.168.1.1 00-aa-bb-cc-dd-ee”.

So the problem with the Arduino Ethernet is that these ARP entries are not being cached and it’s asking the entire network who has the gateway’s IP address every time it sends stuff. Ideally it should cache the IP to MAC address entries, but I’m guessing with limited memory on the Ethernet card this isn’t possible. Also it would be nice if you could tell it in code what the MAC address of an IP is(i.e. the same as “arp -s”), as it’s not very often my router changes MAC addresses.

Thanks, but I think I have that part down. ;)

I just have never checked the ARP broadcast before. Like I said, my wireless and ethernet ports are separate networks. I can bridge them, but I don't. When I do my send every 30 seconds, I am not likely to notice one extra pre-send ARP broadcast unless I was looking.

I do use the DNS thing with the w5100 tho. Instead of using a domain for each send, which does a dns lookup for every send, I do one dns request, then use that ip for a while. That really speeds up things.

edit: I think I see what you are saying now. You think that extra ARP broadcast is causing the mobile device "wake-on-lan" to activate?