Arduino non si resetta e non comunica col pc

Ciao a tutti

ho ricevuto proprio oggi il mio primo Arduino (UNO) e da bravo novellino ho seguito un primo tutorial di base dalla sezione "Apprendimento" di questo sito, esattamente il "Blink" (quello banale del led che lampeggia). Quindi, fatti i dovuti collegamenti e avviato il software, ho fatto l'Upload e l'arduino ha iniziato a far lampeggiare il led. Purtroppo però questo è stato il primo e ultimo upload riuscito... Ogni altro upload che tento non va a buon fine ed esce la scritta rossa: avrdude: stk500_getsync(): not in sync: resp=0x00 avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51. Ho provato a fare un upload anche da un secondo pc con windows xp (sul primo ho W7) ma l'errore è lo stesso :~ Inoltre non riesco a resettare arduino. E' vero non lo conosco bene ma mi aspetto che premendo il tastino reset si cancelli il programma in memoria, invece appena rilascio il tasto si rimette ad eseguire l'unico programma che sono riuscito a caricare e quindi riprende a lampeggiare il led (è normale?). Purtroppo con l'upload bloccato non posso fare altre prove.

Sapreste darmi una mano?

Clax: Quindi, fatti i dovuti collegamenti e avviato il software, ho fatto l'Upload e l'arduino ha iniziato a far lampeggiare il led. Purtroppo però questo è stato il primo e ultimo upload riuscito... Ogni altro upload che tento non va a buon fine ed esce la scritta rossa: avrdude: stk500_getsync(): not in sync: resp=0x00 avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51. Ho provato a fare un upload anche da un secondo pc con windows xp (sul primo ho W7) ma l'errore è lo stesso :~

Hai collegato qualcosa ai Pin 0 e 1? Togli tutto e funzionerá.

Clax: Inoltre non riesco a resettare arduino. E' vero non lo conosco bene ma mi aspetto che premendo il tastino reset si cancelli il programma in memoria, invece appena rilascio il tasto si rimette ad eseguire l'unico programma che sono riuscito a caricare e quindi riprende a lampeggiare il led (è normale?).

Il reset non cancella il programma. Un reset fa partire l'esecuzione del programma dal inizio (con la prime cosa programmata nella funzione setup()).

Ciao Uwe

Ciao, hai controllato che in board sia settato "Arduino UNO" e che la COM selezionata sia quella corretta, sull'altro PC è facile che abbia un nome COMx diverso. Se è tutto a posto l'unica cosa da fare è la manovra d'emergenza, un po' macchinosa ma spesso risolutiva quando Arduino non ne vuole sapere più.

Intanto grazie!

uwefed: Hai collegato qualcosa ai Pin 0 e 1? Togli tutto e funzionerá.

non ho mai collegato nulla a quei pin ed ora di collegato c’è solo l’usb ma nuente.
Il led verde è acceso e quello giallo lampeggia per il programma in memoria…

menniti: Ciao, hai controllato che in board sia settato “Arduino UNO” e che la COM selezionata sia quella corretta, sull’altro PC è facile che abbia un nome COMx diverso.

si è la prima cosa che ho controllato dopo aver letto un po’ in giro ma è tutto ok. La cosa strana è che al primo collegamento ha funzionato subito ma è stata anche l’ultima.
Inutile dire che ho provato a riavviare il pc e a cambiare porta usb ma niente.

menniti: Se è tutto a posto l’unica cosa da fare è la manovra d’emergenza, un po’ macchinosa ma spesso risolutiva quando Arduino non ne vuole sapere più.

di cosa si tratta?

Il tastino di reset non è come il reset del computer, che fa riavviare la macchina e cancella il programma in memoria. La memoria su cui è memorizzato lo sketch non è RAM, che si cancella senza alimentazione, è di tipo Flash e mantiene quindi il programma fino a successiva riprogrammazione.

La Manovra d'emergenza di solito serve quando il micro è bloccato sulla seriale ma a te non sembra bloccato sulla seriale, sembra invece "sordo", nel senso che non comunica più col computer. Comunque è questa: 1) apri l'IDE 2) carichi uno sketch qualunque, anche il "blink" modificato (prova a mettere un delay doppio) 3) prendi l'Arduino e metti il dito sul pulsante "reset". 4) MENTRE tieni questo tasto pigiato, colleghi l'Arduino al PC 5) adesso, MENTRE continui a tenere pigiato il pulsantino, premi il tasto di upload dello sketch 6) ora rilasci il pulsantino di reset 7) se hai trovato la sincronizzazione giusta tra la pressione del pulsante grafico di upload dello sketch ed il rilascio del reset, verrà caricato lo sketch

Dopo diversi tentativi andati male ho reinstallato i driver di arduino e reimpostato la COM giusta e tutto ha ripreso a funzionare :) Era quindi, come suggerito anche da voi, un problema di comunicazione.

grazie ancora a tutti per gli utili suggerimenti...

Io ho provato a seguire la procedura ma non ho risolto il problema!

dovresti però dare qualche informazione in più altrimenti ci vuole la palla di cristallo per aiutarti :fearful: spiega cos'hai, cosa ti è successo, che errore ottieni , ecc. ecc.

Clax: Dopo diversi tentativi andati male ho reinstallato i driver di arduino e reimpostato la COM giusta e tutto ha ripreso a funzionare :) Era quindi, come suggerito anche da voi, un problema di comunicazione. grazie ancora a tutti per gli utili suggerimenti...

Ti invitiamo a presentarti (dicci quali conoscenze hai di elettronica e di programmazione) qui: Presentazioni e a leggere il regolamento: Regolamento - qui una serie di schede by xxxPighi per i collegamenti elettronici vari: ABC - Arduino Basic Connections - qui le pinout delle varie schede by xxxPighi: Pinout - qui una serie di link [u]generali[/u] utili: Link Utili

:stuck_out_tongue_closed_eyes: :stuck_out_tongue_closed_eyes: :stuck_out_tongue_closed_eyes: :stuck_out_tongue_closed_eyes: :stuck_out_tongue_closed_eyes: :stuck_out_tongue_closed_eyes: :stuck_out_tongue_closed_eyes: :stuck_out_tongue_closed_eyes: :stuck_out_tongue_closed_eyes: :stuck_out_tongue_closed_eyes: :stuck_out_tongue_closed_eyes: :stuck_out_tongue_closed_eyes: :stuck_out_tongue_closed_eyes: :stuck_out_tongue_closed_eyes: :stuck_out_tongue_closed_eyes: :stuck_out_tongue_closed_eyes: :stuck_out_tongue_closed_eyes: :stuck_out_tongue_closed_eyes: :stuck_out_tongue_closed_eyes: :stuck_out_tongue_closed_eyes: :stuck_out_tongue_closed_eyes: NIIIIIID Clax si è iscritto, ha risolto il suo problema nell'Aprile del 2011 ed è sparito per sempre:

Name: Clax Posts: 3 (0.002 per day) Position: Newbie Karma: 0 Date Registered: 27 April 2011, 21:20:19 Last Active: 28 April 2011, 01:49:33

Perseguiti anche i morti adesso? Sei un GRANDE! karma +1

No. Per carità. :grin: Ma risulta aver solo 3 post, ovvero quelli di questo thread. Mi son fidato delle statistiche laterali. :grin:

nid69ita: Ma risulta aver solo 3 post, ovvero quelli di questo thread. Mi son fidato delle statistiche laterali. :grin:

Sei appena stato nominato NewbeeHunter con pieni poteri di persecuzione ad vitam aeternam et ab origine. :D :grin: :D

Gooood mooorning Arduiniaaaaam (in omaggio al GRANDISSIMO Robin William! anche se ce n'è pure per il Dear Hunter De Niro)

Praticamente dopo questa incoronazione i newbies non si iscriveranno ad un Forum bensì saranno schiaffati direttamente nella giungla dei Vietcong :stuck_out_tongue_closed_eyes: :stuck_out_tongue_closed_eyes: ]:D ]:D

Non so se questo post è stato o meno risolto, ma allego un video per cercare di sbloccare la comunicazione tra arduino e pc.

https://www.youtube.com/watch?v=plCxXwiUK-w

Holaa!!!

Ti invitiamo a presentarti (dicci quali conoscenze hai di elettronica e di programmazione) qui: Presentazioni e a leggere il regolamento: Regolamento - qui una serie di schede by xxxPighi per i collegamenti elettronici vari: ABC - Arduino Basic Connections - qui le pinout delle varie schede by xxxPighi: Pinout - qui una serie di link [u]generali[/u] utili: Link Utili

andrew3000: Non so se questo post è stato o meno risolto...

Dall'aprile 2011 sono stati aperti non meno di 500 post dove si risolve il problema. :confused:

PaoloP: Dall'aprile 2011 sono stati aperti non meno di 500 post dove si risolve il problema. :confused:

Ciao, e purtroppo ancora l'incubo continua... ormai è da 3 giorni che ho provato qualsiasi cosa, ma ricevo sempre gli stessi errori! avrdude stk500_getsync() not in sync resp=0x00 ... L'unica soluzione vera a quanto pare è acquistare un usb programmer e forzare la scrittura via ISP..

Se l'errore di avrdude è riferito al tuo thread su un atmega 1284, che cosa c'entra con questo thread, relativo a una scheda Arduino Uno o Mega originale ? http://forum.arduino.cc/index.php?topic=429109.msg2960741#msg2960741