Arduino not being detected by PC.

Hello & Happy New Year!

A few days ago my Arduino Mega 2560 rev 3 was connected to my computer which unexpectedly restarted. Since then it is not detected by any of my computers. I tried with Duemilanove which I also have and it worked with same cable & pc. I read that it might be something with 16u2 uc. So I tried to reprogram it with avrdude and my Duemilanove as programmer. Command prompt showed writing, reading then verifying. So everything should be OK (?). But when I connected my Mega it still didn't work. Is there any way to fix it or I have to buy new one?

Regards, MatixYo

PS Sorry for my poor english skill.

From what you explain it appears that the USB drive on the board is not responding for some reason. I would try installing the FTDI drivers just in case although I fear it will not help. That’s a bummer because it appears that other than that it is a working board.
The restarting of the PC may have produced a spike in the input voltage to the board.
Sorry to hear.
good luck

Which one? D2XX or VCP? I used this code to flash:

D:\Programy\arduino-1.0.5\hardware\tools\avr\bin>avrdude -C ../etc/avrdude.conf
-p m16u2 -F -P COM3 -b 19200 -c arduino -U flash:w:../../../arduino/firmwares/at
megaxxu2/Arduino-COMBINED-dfu-usbserial-atmega16u2-Mega2560-Rev3.hex -U lfuse:w:
0xFF:m -U hfuse:w:0xD9:m -U efuse:w:0xF4:m -U lock:w:0x0F:m -v

I toke it from Arduino readme file but it was for 8u2 so I modified it. Maybe something is wrong with my code? If I can communicate with 16u2 throught icsp then maybe there's chance to make it work?