Arduino not discoverable on laptop

Hi everybody,

I'm working on a quadcopter project for a school project. For our quadcopter we are using an arduino uno as the brain of our quadcopter. We are also using the aeroquad v1.9 shield to centralize our connections for our ESC's, receiver, gyro, accelerometer and level converter(all links to our parts can be found below).

We also made our own power distribution cable to connect our battery to our ESC's and our arduino. The battery we are using is a multistar 11.1v 5200 mAh 3s1p LiPo battery. The power distribution cable is basically 4 large wires which attach to the ESC's and a smaller wire which would go directly into the arduino which are all soldered to one wire which leads into the battery. There are 2 power distribution cables for both the positive and negative ends of the battery.

So tonight we connected all our components together and noticed a bit of smoke so we unplugged the battery quickly and tried to make sure that our components still worked. We connected the arduino on its own with the shield attached to our computer and it would not show up as a device on 3 different computers, but both LEDs would still light up.

Looking at both our arduino and shield, there did not seem to be any noticeable burns or damage to any of our parts.

What i'm wondering is if, given our quadcopter parts, is it possible that we fried our arduino when everything was connected and is it possible that our makeshift power distribution cable caused the damage. As far as I understand, the arduino uno can handle up to 12 volts of input, so why would an 11.7v battery cause our arduino to stop working.





level converter: