Arduino Not Getting Power


I've been using my Arduino Uno for a few days now, but tonight things went awry. I connected my Arduino to the USB port of my computer but was surprised to see that the ON, TX, RX, and L leds were not turning on. I tried uploading code, it didn't work. I also tried it out on the other two ports on my computer, to no avail. So I tried connecting it to another laptop I had hanging around, and something strange happened. The leds all turned on for a split second, then off again. I stared at it for a second, then it happened again. They turned on like that about five times, then the Arduino became unresponsive again.

What's wrong? Is it my computer that is the issue, is my board fried, or is my USB C to USB B cable broken? Thank you for your help!

UPDATE: When plugging in the USB B into the Arduino, I now see the green light from the ON led turning on for a split second then slowly fading out. This happens on both the original computer and the other test computer. I tried wiggling it, again to no avail.

Try wiggling the wire next to the ends of the cables and the cable where it's plugged into the USB socket on the Uno to see if there's an intermittent connection that could have caused the behavior you saw with the other laptop.

Yes, I have tried wiggling the wires, but it didn’t help. Thank you for trying!