Arduino Not Receiving Serial Data When Shield Attached

Greetings,

I’m new to arduino, just bought 3WD Omni Nexus Duino. I got problem on serial communication, exactly when the shield is attached, it seem the arduino can’t receive data. When i remove the shield the serial communication doing fine. Anyone have idea what is the issue? Thanks.

Your shield most probably has something connected to pins D0/D1 - that interferes with serial port during upload.
If this is NOT the case - the auto reset may have been diabled. Try holding reset key down, and release it just as arduino IDE says 'uploading'

Do you have a link to that shield?

Thanks for your reply,

To be precise, the product is as described on http://www.aliexpress.com/item/3WD-48mm-Omni-Wheel-Mobile-Arduino-Robot-Kit-10019/688287804.html#magnet-ads

@knut_ny, I'm not sure if it's related to uploading as I have successfully upload my sketchs. Indeed I have to remove the shield before upload otherwise won't succeed, maybe this is what you mentioned that my shield somehow connected to pins D0/D1? But this shield removal thing is also tire me up, because I often change my sketch.

@MarkT, shield board says: Nexus Duino I/O Expansion v1.2 60008, the shield already connected to robot's motors (preinstalled).

So, the problem still exists, after successfull upload I can do serial comm without the shield connected, but not if the shield connected.

Help me, still stuck.

@knut_ny, I've tried hold reset until 'uploading' shows in the IDE but still no luck

.. i got no idea!
Only similar i've seen, is 'not in sync' error, suddenly showing after many succsessful uploads
They solve this by deaktivating/reactivating the com.port

I think my problem is narrowing, it's because the shield use RX & TX (PIN 0 & PIN 1) too so it interfere with arduino serial comm. I'm not really sure but is there a way to check if a shield is actually use RX & TX? And most importantly, can we make it not interfere with serial comm if the shield is indeed use RX & TX? In my case the shield is interfere with capability of arduino to receive serial data, but arduino still can send data to PC.

datasheet : http://www.robotshop.com/media/files/pdf/datasheet-10019.pdf
isn't very informative.., but it says upload should work via USB-port
Ask your supplier for help.

Hi, I’m having the same problem with a mecanum 4wd set… same manufacturers I believe. First, poster is right, once I removed the shield i was able to upload data (this was a problem for 2 days!).

Using his/her program, I am able to get the serial monitor to post the ‘setup’ command, but it does not accept information back over the serial port. Not sure what to do, i’ve contacted the manufacturers and it does not seem like it is a priority.

message to poster Wildflash - have you solved this yet? it sounds like we have the exact same problem…

You need to figure out what the shield is doing with the rx/tx pins.

If it is doing something you don't need, one solution is to cut those pins off the shield, so that they no longer connect to the header on the arduino.

Hi,
Did you find any solutions for the problem? I recently got the same type of robot as in the first post, and I've run into the same problem. (Obviously)

I had a 4WD 10021 Kit and the same issues.
Nexus Robotics tried to help with schematics, docs etc. but ignored my mails when asking for solving theese issues.

I gave up serial communication and tried I2C.

After many wasted hours I found out it's not possible to communicate via I2C with "4WD 60mm Mecanum wheel", because A4/SDA and A5/SDL are blocked by "encoder wires" of "wheel 3 left" - see chapter "The PWM Signal" on page 35 of Nexus_Manual_Eng.pdf.

Proof of concept:
Plug off "encoder wires" of "wheel 3 left" => I2C WORKS but PWM not!
Plug in "encoder wires" of "wheel 3 left" => I2C doesn't work.

Well, no serial communication, no I2C communication, no help... that's very poor features for a robot.

You can free up the serial port by removing the jumpers outlined in yellow here (this disables xbee / rs485 but allows programming with the shield attached)