Arduino not recognised

I have an Arduino Uno R2 which in the past has worked fine, however just now I plugged it into my windows 7 computer and its not recognised at all, not even as an unknown device, it doesn't appear at all under device manager.

I am having the same problem with an XP operating system.

Apparently this is a common problem, but no one seems to have an answer.

Old Man Emu

I wanted to add my voice to this chorus. Same exact problem. Using Windows 7 + Uno. I was able to upload the blink sketch a couple months ago. Didn't touch anything arduino-wise for a couple of months, I go back to play around and upload a new sketch, suddenly Windows no longer sees the Uno at all, not even as an unknown device. Uno is still getting power. I've googled around and can't find an answer anywhere. Tried using different cables and uninstalling/reinstalling the IDE to no avail.

Are youn using the published procedure, or the windows installer program that is available with the IDE? See this thread
http://forum.arduino.cc/index.php?PHPSESSID=j964j3utbhsdfs0lskd39bm884&topic=208278.0