arduino not showing up in device manager

Hello I have an Arduino Uno.

When i plug my arduino uno in i can see that it detects my device as com 3. I can upload code but when i try someting like the SFG demo it says open device failed, please check the device addres and password.
The location of the com is Port_#0002.Hub_#0002. When i open USBDeview i can see there are some not connected.

I looked through other similar posts and I tried following

I tried changing the USB cable. Nothing.
I tried changing the PC 3 times. First with the IDE installed on my windows 10 computer.
I tried the loop back test.
I updated drivers

Any ideas?

(mod edit)

As the driver appears to be from microsoft (pic 4) it may indicate that you do not yet have the correct driver installed.
There are instances where microsoft defaults to its own version/driver for some hardware.

I would presume you did install the IDE from Arduino to pick up the correct drivers ?

Could you take a few moments to Learn How To Use The Forum.
Other general help and troubleshooting advice can be found here.
It will help you get the best out of the forum in the future.

EDIT. I presume that SFG is the fingerprint software but without a link to it ?