arduino not uploading board problem!

so this i the first time in my 4 yrs arduino usage that the arduino is not able to upload sketches to atmega.
i have been using the original one and i even one powers it directly to 12v 10a which resulted in only the ic being burnt(Ps. the power of original).this happened 3 months ago and since was urgent i bought my first uno clone from a local shop.

so just yesterday i was using the clone with a custom shield which converts female headers to male and has l293d mounted which need jumpers to connect to uno digital pins only the vin and ground are connected to it over copper layer.
i uploaded the stepper example and disconnected the clone from computer and gave it 12v 1a dc supply to uno and not shield.
it did work correctly but resulted in burning the ic but what really happened is the uno's rx tx got burnt what i think since even after replacing the ic i can't upload though that ic works with usb ttl and original uno.

i am unable to publish the error code it says exceeds 9000 characters even after removing half error for different post


thanks @spycatcher but this is what i think that the tx and rx are destroyed and i need a way to revive them
and how do i think that is simply because if i upload any code to the atmega and install it in the clone it works such as blink has been tried.
and here is the attached pdf

here is the error.pdf (58.2 KB)


well i have the clone with removable atmega
and yes i have usb ttl and have accomplished in programming atmega using it but i want the uno to do that
that is work like normal

here is the error.txt (33.7 KB)

Now what can I do

Anyone please reply


That seems to be a pretty bad advice since its atmel 16u2 hard to find

Have you tried to replace the firmware on the atmega16u2? Can you use the original Uno as "Arduino as Isp" and flash the atmega16u2?