Arduino not working - PC won't find

Now i've tried with two Arduinos. First an UNO and now and MEGA. Im working at a RGB LED project, using an RGB ampfiller to make it work. (Following this guide: )

My problem is, somewhere in the process something happens, wich make the arduino not work. When i plug it in USB, it starts up and program starts. (have made a custom blink on pin13) and it works. My problem is, nothing happens on the computer. Nothing at all. Not even a error message or any sort of message?

Is both arduinos destroyed, or can i save them? And what cause this?


Regards, Martin

Just noticed the Atmega16u2 chip (USB chip) got really pretty hot - anyone have any idea why?

Maybe something about using 12V power supply same time its connected to USB?

12V connected to USB? How? Why? And yes if you really did that, it would cause huge issues.

No, not via USB -via VIN pin.

That schematics on Instructable has what I think is a mistake: it instructs the user to connect +12V on the LED amplifier to +5V on the Arduino. The way I see it, the amplifier will try to sink more current on this pin that the VR on the UNO can source, since it needs 12V on that connection, not 5V. I find that a terrible idea.

Keep in mind that if your VIN is already 12V, the VR on the Arduino will work pretty hot. 12V is the maximum recommended voltage that can be applied to VIN (although it theoretically supports up to 20V).

If your 12V power source cannot provide enough current to power both the Arduino and the LED strip, it might shutdown or burn, or something like that. Make sure it can provide whatever the LED strips require + the amplifier + about 200mA for the Arduino + 20% (our safety margin).

Also, if the LED amplifier for some reason treats its +12V (on the left side) as an output for the same 12V it receives and VIN on its top pin, those 12V will go directly to the output of the voltage regulator on your UNO. If it is not protected (like the MAX603/604 are), it will blow.

The instructables user writes:

The circuits connect 5v out on the Arduino to 12v on the LED Amp input (common anode). This may seem wierd. I'll try to make some sense of it. The R, B, G inputs of the amp are attached to Arduino digital out. Setting a pin to 0 creates a 5v potential to the common anode which will result on a 12v potential on the corresponding output which will light up the LED. In other words, a digital 0 turns the light on. A digital 1 turns it off. Or, when using PWM duty cycles, 255 is off and 0 is on

It still doesn't make sense, and there are so many wrong things on the paragraph above that it is hard to know where to begin.

If the LED amplifier works on 12V, it's logic high is 12V, not 5V. Whatever sense he tried to make, he failed at it.

When using PWM, 255 is constantly ON, and 0 is constantly OFF. Anything in between determines a cycle of ONs and OFFs on a desired proportion.

Back yo your problem:

there is one possibility: the Atmega 8U2 or 16U2 on your UNO and MEGA might be burn, because of the problems outlined above. They might have gotten damaged from the on-board VR.

If you have a USBASP or another AVR ISP, try reflashing the bootloader on the 8U2 and 16U2.