Arduino now recognised as RAMPS and won't upload sketch

Today I added some software packages for 3D printing.

Now I cannot upload a sketch anymore to my Arduino (clone), since it is recognised as RAMPS (stepper motor driver is seems). I have reinstalled the Arduino IDE but without success.

Error message is the "avrdude etc. ..."

Anyone had this problem, or even better, solved this problem?

Best regards,


since it is recognised as RAMPS

Please explain exactly what you mean by that.

Error message is the “avrdude etc. …”

Giving a tiny generic snippet of the error message is not at all helpful. We need the full error output.

Please do this:

  • File > Preferences > Show verbose output during: > compilation (uncheck) > upload (check) > OK
  • Sketch > Upload
  • After the upload fails you’ll see a button on the right side of the orange bar “Copy error messages”. Click that button.
  • Paste the error messages in a reply here USING CODE TAGS (</> button on the forum toolbar).

Thank you for your quick reply.

I'll add some extra info: I am using Windows 10. My problem after making a connection (USB plugged in) is, that the Arduino will show up in the Device Manager under COM ports as a "RAMPS". This is a driver for a stepper motor.
Previously the original Arduino showed up as "Arduino" and a clone as "CH340".

In the new situation the original Arduino still is "Arduino" but for a clone the CH340 driver no longer loads, since the RAMPS driver is used in stead.

The error message is: avrdude ser_open() can't set com-state for "\\.\COM3"

So my question is, how do I prevent this? Obviously I need both drivers, since I bought a Creality 3D printer.

Best regards,

Make sure you have selected the port of your Arduino board from the Tools > Port menu.

You can find the Arduino board's port like this:

  • Unplug your Arduino board from the computer.
  • Tools > Port
  • Note the ports, if any, listed in the menu.
  • Close the Tools menu
  • Plug your Arduino board into the computer.
  • Tools > Port - The new port listed in the menu is your Arduino board.

There is only one device (the Arduino) connected to my computer, so only one USB port occupied. Therefore it is the Arduino that is associated with the wrong (RAMPS) driver.


Make sure no other program on your computer has that port open. If you have your 3D printer software open, it may have taken over the COM3. You can only have a port open in one program at a time. If you can't find any programs running that might have COM3 open, then try restarting your computer. Sometimes there is a glitch and the port get stuck open.

I have done all that (as I tried yesterday also), but to no result. Still the RAMPS driver is assigned to the Arduino:

I know nothing of Ramps but I would :

  • remove the shield!

  • try a different Arduino or..

  • try the Arduino on a different computer , to see if the problem is the Arduino or the PC.

  • if it’s the Arduino re load the bootloader and try again.

  • if it’s the PC you can get utilities to show what is opening the port ( portmon?). There is stuff on this in google land .