Arduino Official Wifi shield on Arduino 328 - Multibyte write and close issues


I have been having issues converting over a sketch from the ethernet shield over to the wifi shield. Particularly with multibyte writes and closing the connection. I modified the WebServer sketch which exposes these issues(see below). I suspect that they are due to some issues with the SPI driver. If you stay under about 50 bytes on the multibyte write you are fine. If you goto 90 you might be OK. If you goto 100 bytes forget about it. Size of the file doesn’t seem to be a factor. As for the connection, sometimes it closes properly, sometimes it closes too soon, sometimes it doesn’t close at all. Arduino could you fix these issues? Also, could you give people a way to identify the connection(in the ethernet an wifi libraries), specifically the remoteport?



Web Server

A simple web server that shows the value of the analog input pins.
using a WiFi shield.

This example is written for a network using WPA encryption. For
WEP or WPA, change the Wifi.begin() call accordingly.


  • WiFi shield attached
  • Analog inputs attached to pins A0 through A5 (optional)

created 13 July 2010
by dlf (Metodo2 srl)
modified 31 May 2012
by Tom Igoe
#include <SPI.h>
#include <WiFi.h>
#include <SdFat.h>

char ssid = “ssid”; // your network SSID (name)
char key = “key”; // your network password
int keyIndex = 1; // your network key Index number (needed only for WEP)

int status = WL_IDLE_STATUS;

WiFiServer server(80);

SdFat sd;
SdFile file;
uint8_t buf[201];

void setup() {
//Initialize serial and wait for port to open:
while (!Serial) {
; // wait for serial port to connect. Needed for Leonardo only

// check for the presence of the shield:
if (WiFi.status() == WL_NO_SHIELD) {
Serial.println(“WiFi shield not present”);
// don’t continue:

// attempt to connect to Wifi network:
while ( status != WL_CONNECTED) {
Serial.print("Attempting to connect to SSID: ");
// Connect to WPA/WPA2 network. Change this line if using open or WEP network:
//status = WiFi.begin(ssid, pass);
status = WiFi.begin(ssid, keyIndex, key);
// wait 10 seconds for connection:
// you’re connected now, so print out the status:

void loop() {
// listen for incoming clients
WiFiClient client = server.available();
if (client) {
Serial.println(“new client”);
// an http request ends with a blank line
boolean currentLineIsBlank = true;
while (client.connected()) {
if (client.available()) {
char c =;
// if you’ve gotten to the end of the line (received a newline
// character) and the line is blank, the http request has ended,
// so you can send a reply
if (c == ‘\n’ && currentLineIsBlank) {

// send a standard http response header
client.println(“HTTP/1.1 200 OK”);
client.println(“Content-Type: text/html”);
//client.println(“Connnection: close”);

sd.chdir("/");“page.htm”,O_READ); ///page file was a basic html file with lorem ipsum, 1kb-4kb
uint16_t x = file.fileSize();
uint16_t y=100; /// *********************************************bytes to write each time thru loop
if(x<y) {y=x;}
if (c == ‘\n’) {
// you’re starting a new line
currentLineIsBlank = true;
else if (c != ‘\r’) {
// you’ve gotten a character on the current line
currentLineIsBlank = false;
// give the web browser time to receive the data
// close the connection:
Serial.println(“client disonnected”);

void printWifiStatus() {
// print the SSID of the network you’re attached to:
Serial.print("SSID: ");

// print your WiFi shield’s IP address:
IPAddress ip = WiFi.localIP();
Serial.print("IP Address: ");

// print the received signal strength:
long rssi = WiFi.RSSI();
Serial.print(“signal strength (RSSI):”);
Serial.println(" dBm");


You should NOT be diddling with the mode of pin 10 in loop. It MUST be an output pin at all times.

The SD and WiFi libraries should take care of activating the correct slave select pin, so there is no reason for you to be diddling with pin 10 at all. Pin 4, too.

Which WiFi library are you using?


I removed the additional digitalWrite and pinmode commands, same results. I downloaded the WiFi code from the github repository wifishield/libraries at master · arduino/wifishield · GitHub. I tried sketch on ides 1.0 and 1.01 with win xp mach. Have you tried this sketch, does it work for you? I have noticed that this sketch seems to work best with chrome on ff it doesn't seem to catch the end of the request.

I would try uploading the firmware, but I am unsure how to do so. I read online.... "we made updating its firmware very easy, just connect a usb cable to the shield". So, what is the rest of the process?

I noticed that I had a couple misprints on my previous post. Under setup, instead of digitalWrite(10, OUTPUT), it should be digitalWrite(10, HIGH) and the sketch was the WebServer sketch not the WEP sketch. I edited the post with these changes.

I don't think this has anything to do with this, but I noticed that the MAC address is incorrectly labeled on the board.



I don’t this has anything to do with this, but I noticed that the MAC address is incorrectly labeled on the board.

What does this mean? The MAC address on the sticker on the board is the address you are supposed to put in the sketch.

          //client.println("<!DOCTYPE HTML>");
          // add a meta refresh tag, so the browser pulls again every 5 seconds:
          //client.println("<meta http-equiv=\"refresh\" content=\"5\">");
          // output the value of each analog input pin
          //for (int analogChannel = 0; analogChannel < 6; analogChannel++) {
          //  int sensorReading = analogRead(analogChannel);
          //  client.print("analog input ");
          //  client.print(analogChannel);
         //   client.print(" is ");
          //  client.print(sensorReading);
         //   client.println("
         // }

Is it really necessary to post all this commented out code? Delete it!

I'm having the same problem with close issues. I'm working with a sketch that acts as a telnet server to implement a CLI to control a roomba. The WiFi shield closes the TCP connection after about 20 seconds of inactivity, the ethernet shield does not.

The code at GitHub doesn't show a version number, so I guess I'll have to really dig to see if upgrading firmware (nowhere near as easy as advertised) will help. The documentation is pretty sparse in many respects.


I removed most of the commented lines. You use the mac address on the ethernet shield not on the wifi shield.




+1 for me - same here with an UNO R3.
Small files are fine - bigger files are a problem... No chance to get the write to SD Card.

Any news about that?

For the firmware update on the wifi shield this should help you: wifishield/ at master · arduino/wifishield · GitHub

best regards


Yes, there is an issue for sure. When I reduced the bytes per write(50 or less) it seemed to work better. I tried a range of file sizes, 1kb-~20kb, in my testing, it didn't seem to effect the results.

I didn't try writing, so no comment on that.

Thanks for the link, but still not sure of the process on updating. Do you use avrdude to compile and upload? Did you update the firmware and still have problems? If you did, I will wait to for the Arduino guys to update the firmware.



@diesel look here for details on updating? Arduino Forum


Thanks for the link on updating the firmware. Did the update help with communication issues with the shield?