Arduino on a breadboard with ftdi problem stk500_getsync(): not in sync: resp=0x

Hello World, I guess I am late to the show...just bought my first Arduino a couple weeks ago. It is an UNO R2. I downloaded the latest Arduino IDE, which says 1.0.5.

I am here desperately seeking a little help. Must admit to being nothing but frustrated, can not believe how many hours spent on this thing, not one process that I have followed step by step per forums advice, Arduino website, common intuition, etc. has worked the first time around. This includes installing the IDE, burning bootloader onto new atmega328 chips, building Arduino on a breadboard, etc.

But so far at least a few things I have attempted were finally resolved one way or another.

Except this: So I would like to build a standalone Arduino on a breadboard, and then eventually a pcb. I can immediately think of several different projects that I would like to use this on. But I have precisely followed the instructions here: http://arduino.cc/en/Main/Standalone and remain unable to download sketches....here are the things I have done:

First, I am using a Windows7 64bit pc. I bought the UNO R2 with Atmega328p-pu. Once I finally got the Arduino IDE installed and working, I was easily able to burn the blink sketch as well as others. I bought two new Atmega328p-pu and one newAtmega328-pu (all without bootloader) in order to hopefully experiment and learn more about the bootloader deal. What a mistake. Somehow however, after many unsuccessful attempts at burning the bootloader from instructions here: http://oddwires.blogspot.com/2012/06/burning-bootloader-into-bare-atmega328.html and here: http://arduino.cc/en/Tutorial/ArduinoToBreadboard and here: http://www.instructables.com/id/Burning-the-Bootloader-on-ATMega328-using-Arduino-/ and several other places as well, I finally seem to be able to upload sketches onto any of these chips when installed onto the UNO R2. I hazily recall some things involving modifying boards.txt and avrdude files. Dont ask me which methods worked on what chips, all I see is blurrr. So next I built the breadboard circuit here: http://arduino.cc/en/Tutorial/ArduinoToBreadboard ......the one at the very bottom right. and relocated, one at a time after testing on the UNO R2, each of the atmegas from the UNO R2 to the breadboard. I also added the 16mhz crystal and caps. And a resistor and led to pin 19 for testing the blink sketch. I was, and still am able to download sketches to any of the atmegas when configured this way on the breadboard. But I am still tied to the UNO R2. So then I bought this: http://www.ebay.com/itm/261245245140?ssPageName=STRK:MEWNX:IT&_trksid=p3984.m1439.l2649 which I understand to be a FTDI FT232RL USB to serial gadget so that I can communicate to my new standalone Arduino clone from my pc. ... and thinking this would finalize my breadboard circuit and that I could build a pcb to basically have a clone of my UNO R2. I have wired it to my breadboard as follows: usbgadget pin TX to atmega pin 2; usbgadget pin RX to atmega pin 3; usbgadget VCC to +5v rail; usbgadget GND to ground rail and have tried all sorts of twisted things including: swapping out 3 different usb cables; swapping TX and RX connections; jumping DTR to atmega pin 1, with and without a .1uf cap between; 1k pullup resistors between +5 and RX and TX; pushing reset at all different times during the upload sketch process, etc, with each and every different combination of the various earlier mentioned twisted solutions applied that I could think of. But , of course, once again no joy here, I cannot get any sketches to download to the atmega's and have tried a million and one things....all resulting in the dreaded common avrdude: stk500_getsync() : not in sync: resp=0x00 When I do hit the upload sketch , there are some brief flashes from the TX and RX leds on the usbgadget( too fast to tell which ones exactly) and the trusty atmega pin 19 led blinks rapidly maybe 3 to 9 times, depending on how much more blurry my vision has become. The device manager on the pc lists USB serial port(COM 5) when I plug in the usbgadget and further shows something about it working correctly with the most current FTDI drivers. meanwhile, whatever atmega is on the breadboard continues to blink away, convincing me that most likely the connections are all good.

I guess that is about as much as I can think of right now. I sure will appreciate anyone helping nudge me towards a solution, I know it is alot to ask after reading this thesis :D I have written, but it was not fun for me either.....I think I have included about as much relevant information as could be asked for, and I sure hope I have not wasted yet more time here.

Cheers, Bill

Due to the overwhelming support I received from the lovely Arduino community here, I feel it is my responsibility to give some back! You know… pay it forward! :smiley:

**I must admit I was finally able to get the previously linked usbgadget to work albeit somewhat sketchy. I was able to get sketches loaded onto the Atmega on a breadboard, but there were some very glitchy things going on, including my PC hanging up several times. I managed this by going through some convoluted process of uninstalling this and that driver, and reverting to an older FTDI usb driver. To me, the $20 bucs for the real deal FTDI gadget explained later is money well spent, even though those with more skills than I probably consider me a sucker.

So…I seem to have solved my “usb gadget no worky” problem and I am going to explain what worked for me. YOUR mileage may vary. I would have UNDOUBTEDLY chosen this route in the first place, had I known.
Perhaps this will help someone else out.

After reading for days on end everything I could find involving the “stk500_getsync(): not in sync: resp=0x00” error, which is ALOT, and at the same time understanding none of it, I came across this thread…http://forum.arduino.cc/index.php?PHPSESSID=8u7kvkiolsm9hrd8mdkar-lk8o7&topic=173676.msg1311792#msg1311792

and more importantly…reply #4 regarding the authenticity of the FTDI chip on many of the usb to whatever gadgets from large E commerce sites.

so I hesitantly forked out the big bucks for this…http://www.digikey.com/product-detail/en/UM232R/768-1019-ND/1836397 which turns out to be more than I contributed for the used UNO itself, but I considered it to be in the name of being more learnt, no one ever said education is free.
Not having a clue what it actually does, but reasoning that it MUST BE what I needed, since it did indeed have an FTDI ic and a USB connection, I took my chances. I assumed it likely utilized a non-counterfeit FTDI chip provided my favorable past experience with the supplier.

I then built the Arduino on a breadboard per the instructions with the following changes:

  1. I did not mess with any of the 7805 power supply components, I expected power to come via the usb.
  2. I added the UM232R to the breadboard and made these connections:
    pin 1(TXD) of the UM232R to pin 2(RXD) of the Atmega328p
    pin 2(DTR#) UM232R to one lead of 1uF capacitor (don’t know if it’s necessary, I found the suggestion to use a .1uF in my miles of travels but could only find a 1uF at the moment)
    the other lead of the 1uF capacitor to pin 1(reset) Atmega328p
    pin 5(RXD) UM232R to pin 3(TXD) Atmega328p
    pin 7(GND) UM232R to ground rail
    pin 21(VCC) UM232R to +5v rail
  3. Connect a 2k resistor between +5v rail and pin 2(RXD) Atmega328p, and another 2k resistor between +5v rail and pin 3(TXD)Atmega328p (again, found the suggestion to use 1k but only had 2k available)

Low and behold, all my problems disappeared, and I can easily load sketches onto the breadboard Atmega now.

Anyhow, I’ve grown weary of talking to myself, in spite of the fact that it is a requirement since no one else will talk to me, so farewell, case closed on my end.

Good Luck, if you’re reading this you probably need it,
Bill

Dear Mr. Billcat, I now have the same problem as you had. Until about a month ago I was able to upload via USB2Serial adapter onto my barebone PCB Arduino but now it is simply impossible. I keep getting the infamous error "....not in sync: resp=0x00". The funny thing (or should I say baffling) is that everything worked like a charm back a month ago. I did everything by the book. Your previous post - is simply GREAT ! Couldn't have written it better myself.... I'm still baffeld and it's been a frustrating month of search, read, try, burn, install, reinstall--> then allover again: search, read, try, burn, install, reinstall.... Anyway, I'm glad you have resolved your problem. I guess living in the states has it's up side. I myself living in Serbia am having a very difficult time shopping on-line..... Sincerely, Vladimir Stojanovic....

How about putting here all the extra info you sent in that personal message to me? Then at least we have something to discuss.

Dear Mr. Nick, I have visited you site at (www.gammon.com.au/) and read 'almost' everyhing you have written about DIY-Arduino projects. Great site indeed ! So to cut to the chase, I'm having a rather baffling situation: I am not able to upload any sketches to a barebone Arduino using a USB2Serial adapter nor a serial/TTL cable. I keep getting the infamous error "....not in sync: resp=0x00". The baffling part is that I'm pretty sure that all the hardware is functioning ok (or is it?) What would be the first thing an expert like you would assume is going wrong? I have tried the following: - burning bootloaders to new Atmega chips, (verified using your code == all OK) - made a breadboard version of Arduino (MintDuino) - used several new Arduino UNO REV3 - used several new USB2SerialLight adapters and the list goes on

I have to mention that uploading sketches via Arduino as ISP programmer works fine every time. Even when burnning the bootloader on to a fresh chip I never get any errors. But when I try to upload using a USB2Serial (or Serial to TTL) I get the above mentioned error.

I am sorry for having to bother you via IM, I will post this on the forum but I'm not eaxctly sure where.

Thank you for any input on the matter.

Sincerely, Vladimir Stojanovic

Since the last IM I have some "flash news": Somehow almost everything is as it should be using my "DIY Serial to TTL adapter" - but the problem with the FTDI cable is still here. Concerning the TTL/serial thing it seems I had the cables a bit mixed up along with the boud rate (must be set to 9600 !), so now I definetly know the burning, and all of the hardware is OK - leaving the FTDI adapter as the culprate...

OK so here are some pictures of what I'm talking about: https://www.dropbox.com/s/6q7dowpxg5nkcst/Arduino%20on%20BreadBoard.JPG https://www.dropbox.com/s/v7v50ftvk00vck0/IM002612.JPG https://www.dropbox.com/s/ihuzu8p0m7vsy68/MAX232%20-%20DSub9%20-%20PCB%20-%20Close-up%20-%20008.JPG

hope the pics can be seen and/or links work....

VS

I'm not a big fan of going to off-site picture collections. You can do attachments right here you know.

How to use this forum

Somehow almost everything is as it should be using my "DIY Serial to TTL adapter" - but the problem with the FTDI cable is still here.

Which FTDI cable? Link?

OK - I hope this time I’ll get things right:
pics (using attach)
And my mistake, it’s not an FTDI cable but an Arduino USB2Serial Light (shown on the picture) - which BTW is still not responding - keep getting the above mentioned “sync” error…
The 2nd pic: 3 versions of DIY-Arduino. OK so not exactly barebone but can’t find the correct term… All of them work fine using the DIY TTL/Serial adapter…
On the last (3rd) picture is my TTL/Serial DIY adapter which works like a charm…

Oh, and thank you for the instructions - I thought the insert picture would do the trick but the attach thing is far better :slight_smile:

Arduino on BreadBoard - USB2Serial - 3.JPG

IM002612.JPG

MAX232 - DSub9 - PCB - Close-up - 008.JPG

Hi all ! Finally got the USB2Serial adapter thingy to work again. I simply reinstalled everything on a new machine (netbook; Win7; 32bit) and everything is back on tracks as before. I would like to thank the Arduino community since I have learned so much (and I really mean that !) in these past few weeks.

Keep up the GREAT work guys !

Sincerely, Vladimir Stojanovi?

Glad it's working now. :)

I am trying to upload pics but in a fashion where they will be embeded, so here goes nothin - hope it works finally this time......

Here is the MintDuino with the USB2Serial adapter

My DIY TTL/Serial adapter

From right to left: - DIY programmer board for Atmegas; - 2nd version of DIY standalone Arduino; - my very 1st DIY standalone Arduino.... - and last but not least the original ArduinoUNO3 for comparison purposes - (below is a matchbox)