Arduino on the ATMEGA168

Ok - I made a real page for someone to go to to buy Atmega168/8s preloaded with Arduino firmware. http://asecular.com/arduino/

I've tried this and got it the boot loader burned and everything appears to be working, except for one thing. Does anybody else observe that the orange light blinks slower on boot/reset than on the atmega8? I also have motors that take servo commands to set the speed and they appear to be going slower. Though this could be all in my head. Anybody else notice anything like this? Is there a way to measure if the atmega168 is running at the right speed? I've gone round and round with the fuses (causing me to burn out my mega8 so i can't compare it) and i haven't been able to get light to blink faster on boot. This could of course just be in the code for the 168 boot loader though. Anybody have an insight?

I can assure you that you are imagining the speed difference. I have used Atmega8s and Atmega168s in the same socket with the same circuitry and have never seen speed differences when executing identical programs, some of which do nothing but record the time, iterate through thousands of loops, and then record the time again.

Of course, if you have the fuse settings set wrong, it’s possible to, say, have the Atmega168 cranking along at only 1MHz, but in those cases its serial port will not work with the default settings for the Arduino IDE and you’d have an objective sense of the problem instead of the subjective one you describe.

Ah, thanks for the assurance. It doesn't seem like I could slow it down the little bit that it seems with the fuses anyway.

Not that this discussion should be happening here, but I did mail them.

It seems there's a downside to depending on international mail to make people happy. Obviously, if they don't arrive then you get a refund.

I can't tell if I've had this issue the entire time I've been using a 168 or not, but at the moment, in order for the programs i download to the chip to run, I need to briefly plug in the usb cable. I can then unplug it, and after the bootloaders wait time, the program will run. It does this even with the led_blink program, so it has to do with either the bootloader or whatever happens before the bootloader. Both pressing the reset button, or reseting the power will cause it to have this problem. I've tried two different chips, tried all the bootloaders i can find. Tried uisp and avrdude. Anybody have an insight to why this is happening? I'm using the arduino on a robot that is only connected to usb to download, so it's very annoying to have to plug it in every time i want to start it. Fuse settings i'm using are: hfuse 0xDF lfuse 0xFF efuse 0xF8 lock 0xCF

put a 100k pulldown resistor on RX and you'll be fine...

this must be the biggest FAQ about arduino.. :) :)

massimo

Wow, that did it… Thanks

still waiting for my 3 atmega168 to arrive from bigfun!

they arrived this morning!!!

thanks bigfun for the kind offer to return the money or send a new batch. excellent service.

erik