Arduino plotting error “command not recognized” m18 (GRBL + G-CODE)

I'm new to Arduino and I am creating a project called (DIY CNC PLOTTER) for my final design project in school, the following are the list of part that I'm currently using.

Hardware:

1 Arduino Uno v3
1 L923D Shield
2 DVD Stepper Motor
1 Micro Servo S90 Motor
1 12V and 5V supply (This is made of PC power supply, but I'm only using 5V)

Software:

XLOADER
GRBL 1.1 Hex File connected to UGS (This never worked for me)
GRBL 0.8 Hex File connected to UGS (This never worked for me)
UGS (No response at all from lower to higher version)
Processing 3.3 (this works fine for me but it has on very limited functions)
GCTRL (The up and down and left to the right arrow has no response)
Inkscape (Works fine)
ERROR:

M18 (Drive off)

command not recognized: m18

As of now, that is the error which I'm currently having during the plotting process. I've scoured the internet day and night hoping to find an answer to this issue but the more I read the more I get confused. But I've read in some post that the problem is that the GBRL CODE is not supporting the M18 and M17 G-Code, so is there any way that I can tweak the GRBL code to remove add the M18 and M17 to make it work?

I watched so many tutorials and followed the same process on how to flash Arduino using but still no luck, I hope you guys can help me to solve this problem.

GRBL uses a subset of GCODES and due to the extreme limitations of the Arduino memory not all can be used.

Have you tried the M5, M4, M3 commands ?
There is also some very good write ups on the GRBL wicki as to what is and is not supported.

This is also possibly the wrong section of the forums for this topic.