Arduino Pro Mini: unable to upload sketch

Hello!

I brought some days ago my first Arduino Pro Mini (5V 16MHz with ATMega328), the one produced by SparkFun: http://www.sparkfun.com/products/11113

From the same webshop, I also brought the "official" usb-to-serial adapter: http://arduino.cc/en/Main/USBSerial

I've already worked with Arduino boards, but only with 2009 and Uno that have usb->serial onboard...

I read that my two boards (adapter and Pro Mini) share the same pinout, so I soldered a 6-pins connector on Pro Mini and I connected it with my adapter. As soon as I connect the usb cable to my laptop, the red led on Mini Pro turns on, so I assume power supply is present. When I click the reset button, the green led (I think connected to pin 13) flashes.

I'm trying to upload the blink example: I choose from the IDE (version 1.0) the correct COM port, "Arduino Pro o Pro Mini (5V 16MHz) w/ATMega 328" as board but upload fails...

If I turn debug mode on, here's what I get:

Binary sketch size: 1026 bytes (of a 30720 byte maximum)
C:\arduino-1.0\hardware/tools/avr/bin/avrdude -CC:\arduino-1.0\hardware/tools/avr/etc/avrdude.conf -v -v -v -v -patmega328p -carduino -P\\.\COM19 -b57600 -D -Uflash:w:C:\TEMP\build4514040347170019869.tmp\Blink.cpp.hex:i 

avrdude: Version 5.11, compiled on Sep  2 2011 at 19:38:36
         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
         Copyright (c) 2007-2009 Joerg Wunsch

         System wide configuration file is "C:\arduino-1.0\hardware/tools/avr/etc/avrdude.conf"

         Using Port                    : \\.\COM19
         Using Programmer              : arduino
         Overriding Baud Rate          : 57600
avrdude: Send: 0 [30]   [20] 
avrdude: Send: 0 [30]   [20] 
avrdude: Send: 0 [30]   [20] 
avrdude: Recv: 
avrdude: stk500_getsync(): not in sync: resp=0x00

avrdude done.  Thank you.

What's the problem? When the uploading process starts, the green led blinks so I assume that IDE is able to reset my board...

Thanks!

You might want to contact SparkFun about the issue. They seem to have a known problem with the bootloader, this note is on the site you just linked to:

Note: If you are having problems with loading code, please contact techsupport@sparkfun.com. A few of our customers are experiencing problems with the bootloader.

Thanks Louis, I missed that line ;)

Hello!

I solved thanks to SparkFun support: some of their Arduino Pro Mini were shipped with UNO bootloader... choosing this one as device in Arduino IDE solved my problem. The support helped me also to upload the correct bootloader to my board.

bye

This is actually a bug in the Arduino IDE 1.0, not the Mini.

Older Mini's with ATmega328 should select board type Duemilanove. Newer Mini's with ATmega328 should select board type UNO