arduino problem

I am trying to make, my own arduino board but I cant get the arduino ide to send program to
board. I watch a youtube video call "$2 Arduino The ATMEGA328 " and I cant get pass the 3:10
part of the video. instead I get this message on the bottom. Please help.

Arduino: 1.8.8 (Windows Store 1.8.19.0) (Windows 10), Board: "ATmega328 on a breadboard (8 MHz internal clock)"

Warning: Board breadboard:avr:atmega328bb doesn't define a 'build.board' preference. Auto-set to: AVR_ATMEGA328BB
Bootloader file specified but missing: C:\Users\Scotty Willimas\Documents\Arduino\hardware\breadboard\avr\bootloaders\ATmegaBOOT_168_atmega328_pro_8MHz.hex
Sketch uses 4400 bytes (14%) of program storage space. Maximum is 30720 bytes.
Global variables use 482 bytes of dynamic memory.
Error while uploading: missing 'upload.tool' configuration parameter

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.

Hi,
Welcome to the forum.

Please read the first post in any forum entitled how to use this forum.
http://forum.arduino.cc/index.php/topic,148850.0.html .

Have you tried to contact the originator of the YouTube at.

He also has a facebook and a website.

Tom... :slight_smile:

This Arduino breadboard tutorial may be useful.

Also look at Nick Gammon's diagnostic programs.

...R

SIRMAX1:
Warning: Board breadboard:avr:atmega328bb doesn’t define a ‘build.board’ preference. Auto-set to: AVR_ATMEGA328BB
Bootloader file specified but missing: C:\Users\Scotty Willimas\Documents\Arduino\hardware\breadboard\avr\bootloaders\ATmegaBOOT_168_atmega328_pro_8MHz.hex

You either have to define a “build.board” preference, or download the indicated bootloader file.

DrDiettrich:
You either have to define a "build.board" preference, or download the indicated bootloader file.

The build.board thing is not the problem. It's just a warning. The Arduino IDE automatically sets that property when it's missing.

SIRMAX1:
Error while uploading: missing 'upload.tool' configuration parameter

This indicates that you have downloaded and installed the "Breadboard1-5-x.zip" version of the "ATmega328 on a breadboard" hardware package. That version is incompatible with the Arduino IDE 1.8.8 you're using. The version you need to use is "breadboard-1-6-x.zip".

Here's how you can fix it:

  • Delete C:\Users\Scotty Willimas\Documents\Arduino\hardware\breadboard
  • Download the correct version of the hardware package: https://www.arduino.cc/en/uploads/Tutorial/breadboard-1-6-x.zip
  • Unzip the downloaded file.
  • Copy the unzipped folder "breadboard" to C:\Users\Scotty Willimas\Documents\Arduino\hardware.
  • Restart the Arduino IDE.

I try following the direction, but when I try to burn the bootloader the program I get this message.

Arduino: 1.8.8 (Windows Store 1.8.19.0) (Windows 10), Board: "ATmega328 on a breadboard (8 MHz internal clock)"

Warning: Board breadboard:avr:atmega328bb doesn't define a 'build.board' preference. Auto-set to: AVR_ATMEGA328BB
Sketch uses 4400 bytes (14%) of program storage space. Maximum is 30720 bytes.
Global variables use 482 bytes of dynamic memory.
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0xd9
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0xd9
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 3 of 10: not in sync: resp=0xd9
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 4 of 10: not in sync: resp=0xd9
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 5 of 10: not in sync: resp=0xd9
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 6 of 10: not in sync: resp=0xd9
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 7 of 10: not in sync: resp=0xd9
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 8 of 10: not in sync: resp=0xd9
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0xd9
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0xd9
Problem uploading to board. See Arduino Help Center for suggestions.

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.

Please help me. I don't know what I'm doing wrong?

Please do this:

  • File > Preferences > Show verbose output during: > compilation (uncheck) > upload (check) > OK
  • Tools > Burn Bootloader
  • After the process fails you’ll see a button on the right side of the orange bar “Copy error messages”. Click that button.
  • Paste the error messages in a reply here USING CODE TAGS (</> button on the forum toolbar).

this is what I got.

Arduino: 1.8.8 (Windows Store 1.8.19.0) (Windows 10), Board: "ATmega328 on a breadboard (8 MHz internal clock)"

C:\Program Files\WindowsApps\ArduinoLLC.ArduinoIDE_1.8.19.0_x86__mdqgnx93n4wtt\hardware\tools\avr/bin/avrdude -CC:\Program Files\WindowsApps\ArduinoLLC.ArduinoIDE_1.8.19.0_x86__mdqgnx93n4wtt\hardware\tools\avr/etc/avrdude.conf -v -patmega328p -carduino -PCOM8 -b19200 -e -Ulock:w:0x3F:m -Uefuse:w:0x05:m -Uhfuse:w:0xDA:m -Ulfuse:w:0xE2:m

avrdude: Version 6.3-20171130
Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
Copyright (c) 2007-2014 Joerg Wunsch

System wide configuration file is "C:\Program Files\WindowsApps\ArduinoLLC.ArduinoIDE_1.8.19.0_x86__mdqgnx93n4wtt\hardware\tools\avr/etc/avrdude.conf"

Using Port : COM8
Using Programmer : arduino
Overriding Baud Rate : 19200
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_recv(): programmer is not responding

avrdude done. Thank you.

Error while burning bootloader.

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.

Did you upload File > Examples > 11.ArduinoISP to the board you're using as an Arduino as ISP programmer?

Well I still get this.

Arduino: 1.8.8 (Windows Store 1.8.19.0) (Windows 10), Board: "ATmega328 on a breadboard (8 MHz internal clock)"

Warning: Board breadboard:avr:atmega328bb doesn't define a 'build.board' preference. Auto-set to: AVR_ATMEGA328BB
Sketch uses 4400 bytes (14%) of program storage space. Maximum is 30720 bytes.
Global variables use 482 bytes of dynamic memory.
C:\Program Files\WindowsApps\ArduinoLLC.ArduinoIDE_1.8.19.0_x86__mdqgnx93n4wtt\hardware\tools\avr/bin/avrdude -CC:\Program Files\WindowsApps\ArduinoLLC.ArduinoIDE_1.8.19.0_x86__mdqgnx93n4wtt\hardware\tools\avr/etc/avrdude.conf -v -patmega328p -carduino -PCOM8 -b57600 -D -Uflash:w:C:\Users\Scotty Willimas\AppData\Local\Temp\arduino_build_533115/ArduinoISP.ino.hex:i

avrdude: Version 6.3-20171130
Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
Copyright (c) 2007-2014 Joerg Wunsch

System wide configuration file is "C:\Program Files\WindowsApps\ArduinoLLC.ArduinoIDE_1.8.19.0_x86__mdqgnx93n4wtt\hardware\tools\avr/etc/avrdude.conf"

Using Port : COM8
Using Programmer : arduino
Overriding Baud Rate : 57600
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0xa6
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0xa6
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 3 of 10: not in sync: resp=0xa6
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 4 of 10: not in sync: resp=0xa6
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 5 of 10: not in sync: resp=0xa6
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 6 of 10: not in sync: resp=0xa6
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 7 of 10: not in sync: resp=0xa6
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 8 of 10: not in sync: resp=0xa6
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0xa6
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0xa6

avrdude done. Thank you.

Problem uploading to board. See Arduino Help Center for suggestions.

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.

Hi,
Did, File > Examples > 11.ArduinoISP, upload okay to the UNO?

Tom.. :slight_smile:

Thats the info I got in red when trying to upload it to the board.

I use this for my breadboard setup

breadboard1.png

breadboard1.png

Hi,
So you get that error just trying to load, File > Examples > 11.ArduinoISP ?

Did you have UNO selected as the controller when you tried to load File > Examples > 11.ArduinoISP code?

Tom.... :slight_smile:

I set it up like this.

You need to select the board that matches your programmer board when you are uploading to that board. If your programmer board is an Uno, then you need to select Tools > Port > Arduino/Genuino Uno Correction: Tools > Board > Arduino/Genuino Uno.

Hi,
arduinohelp.jpg

Tom… :slight_smile:

This is what I got.

If you disconnect all wires between the Uno and the breadboard, are you able to upload to the Uno then?

This is what I got. I pull out all the wire connected to the breadboard.

Arduino: 1.8.8 (Windows Store 1.8.19.0) (Windows 10), Board: "Arduino/Genuino Uno"

C:\Program Files\WindowsApps\ArduinoLLC.ArduinoIDE_1.8.19.0_x86__mdqgnx93n4wtt\hardware\tools\avr/bin/avrdude -CC:\Program Files\WindowsApps\ArduinoLLC.ArduinoIDE_1.8.19.0_x86__mdqgnx93n4wtt\hardware\tools\avr/etc/avrdude.conf -v -patmega328p -carduino -PCOM8 -b19200 -e -Ulock:w:0x3F:m -Uefuse:w:0xFD:m -Uhfuse:w:0xDE:m -Ulfuse:w:0xFF:m

avrdude: Version 6.3-20171130
Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
Copyright (c) 2007-2014 Joerg Wunsch

System wide configuration file is "C:\Program Files\WindowsApps\ArduinoLLC.ArduinoIDE_1.8.19.0_x86__mdqgnx93n4wtt\hardware\tools\avr/etc/avrdude.conf"

Using Port : COM8
Using Programmer : arduino
Overriding Baud Rate : 19200
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x85
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0x85
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 3 of 10: not in sync: resp=0x85
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 4 of 10: not in sync: resp=0x85
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 5 of 10: not in sync: resp=0x85
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 6 of 10: not in sync: resp=0x85
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 7 of 10: not in sync: resp=0x85
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 8 of 10: not in sync: resp=0x85
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0x85
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0x85

avrdude done. Thank you.

Error while burning bootloader.

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.