Arduino ProMini bricked ? (red led is on)

Hello guys,

I have some problems with a device that is using two 328p chips (FBOSD is called and contains an arduino pro mini and a Minim OSD)

First time I was able to connect to both and configure the firmware installed on both, but after I soldered minimOSD and installed it on my hexacopter I noticed there was no signal on the video out pin (my mistake was I did not test it, only after I mounted it. ..I don't know if it worked inthe beggining)

.. anyway, now I can't connect to any of the boards, I have a spare Pro Mini board, and I have tried to install the FBOSD firmware on it, it worked multiple tymes with the same FTDI cable. But everytime I try to connect to the original board or to the OSD with the same cable it fails like this:

avrdude: stk500_getsync(): not in sync: resp=0x00

I tried to upload a simple sketch using Arduino 1.0.5 , on my spare pro mini it worked perfectly, but on the other pro mini I get the error you see above.

Are my boards bricked ? Can I do anything to make it work again ?

PS. The MinimOSD board just shows a black screen, I found a thread about this problem to minimOSD and sopme guys say I have to burn the bootloader again, I'll try that too but first I have to find out which is the ISP pin order on MinimOSD board