Arduino Robot Motor Board, powered but no com port, no response

Hi everyone,

I didn't find a specific category for the Arduino Robot A0000078 but if there is one I hope a mod can move my post.

I bought this secondhand but was assured it was fully functional. The Control Board was a bit difficult to programme but eventually I got the double-tap on the reset correct and triggered the bootloader, now it works and can be programmed fine. However I cannot connect to the motor board. So far the seller has not responded to my queries about this problem and I've not found a solution myself.

When I connect the motor board my computer it is not recognised and does not get a COM port assigned, it doesn't appear in Device Manager at all even as an unknown device. I've tried more than one Windows 10 computer and tried Ubuntu as well. I've tried all troubleshooting suggestions I can find including replugging the USB connection, using different USB ports on my computer, restarting the IDE, double-tapping the reset button at various points including when the IDE says "uploading". Nothing makes the board respond at all.

I don't know what sketch is currently on the board but when I load a test like "Motor Test" example on the control board, disconnect the USB, put the robot on the floor and turn on the power (fully charged batteries), the robot does nothing, no movement.

The red LEDs on the motor board do come on when I have power on and lift the robot from the floor, but I see from the schematics that these appear to be independent of the MCU so are no indication of it is working or not.

Does anyone have any ideas of how to test and resolve this problem please? Is this is a sign of a corrupted bootloader? Does it mean the MCU is dead? How to test these things?

Thanks :slightly_smiling_face:

Moved to Robotics

1 Like

Hi

Can you post a link to your robot please?

Thanks.. Tom... :grinning: :+1: :coffee: :australia:

Hi @TomGeorge,
It's this one:
https://store.arduino.cc/arduino-robot
https://www.arduino.cc/en/Main.Robot

Cheers :slightly_smiling_face:

Hi @UKHeliBob ,

Is this really the right forum? The thread isn't getting much interest and would like some help urgently as otherwise I'll have to say the seller has sold me duff goods and ask for my money back.

I've tried to troubleshoot using the schematics but not got very far. Nothing i try with software works. I would very much appreciate some help from either someone who knows this Arduino Robot or the 32u4 microcontroller.

If not the Arduino forums can you recommend any other place i could find some help?

Cheers :slightly_smiling_face:

Your problem relates to robotics, hence me moving it here. I will happily move it to the Project Guidance section of the forum if you think that will help.

Hi @UKHeliBob, i've no idea which category is best, just wondering. I think my issue is related to the microcontroller communication itself (32u4) rather than the rest of the board.
Cheers :slightly_smiling_face:

Topic moved to Project Guidance where it may get more views

1 Like

Thanks @UKHeliBob,

I looked up some advice for the Leonardo, since it uses the same MCU (32u4). It suggest holding down reset from before clicking Upload to until Uploading... appears. I tried this several times and it doesn't work.

A few other notes. When I plug in USB or turn the power switch on (fully charged batteries) the green On LED on the motor board does not come one but it does on the control board, as well as the LCD lighting up. When I connect to the 9V power socket the On and Charging LEDs both light up.

Should the green On LED light up with USB connected or Power switch On?

I also tried removing the LCD screen and this didn't change any behaviour.

I am beginning to feel that I might need to try reflashing the bootloader, but I don't have time to do this before my deadline for sending it back. Also reflashing the bootloader is probably not advised if I'm going to return this.

All ideas much appreciated.

Cheers :slightly_smiling_face: