Arduino senza java?

Esiste un IDE per windows non java ma nativo? Ho l'ambiente java tutto incasinato, e il piu' delle volte l'IDE non mi parte, o se parte si blocca quando seleziono TOOLS, o non fa l'upload...

no; Java é necessario. Ciao Uwe

A me pare di capire di si invece: http://www.arduino.cc/playground/Main/DevelopmentTools

Però poi ti incasini

bhè volendo puoi fare tutto da riga di comando... scaricati l'ultima versione di java che fai prima :-)

disinstallato e reinstallato Java, non funziona lo stesso:

doppio click su arduino; *compare splash screen; *rimane lì **per 5 o 6 minuti* :-?, intanto faccio altre cose... "Bling" (segnale acustico di errore): dialog di errore, ci sono stati problemi nell'avvio dell'applicazione, posso solo premere OK; *ridoppioclicco, stessa storia. *altro doppio click, uguale. *lascio perdere. *dopo 10 minuti appaiono **3 finestre* dell'IDE. :o *vado sul menu TOOLS: blocco totale dell'applicazione. Stessa cosa per tutte e tre le finestre. E' impossibile anche chiuderle. * lascio perdere e mi metto a fare altre cose. * dopo 10 minuti rivado su una delle finestre: è comparso il menu TOOLS... :-? Seleziono Arduino Uno.... e si riblocca tutto...

ecchepalle....

Ma da che puo' dipendere???

Ma non posso semplicemente compilare & linkare il tutto con un file batch, come ai vecchi tempi? E poi lanciare a mano l'uploader? Sul sito ci sono alcune spiegazione dei passi compiuti dall'IDE, ma non sufficientemente dettagliate. http://arduino.cc/en/Hacking/BuildProcess

edit: qualcuno puo' per favore mandarmi il suo file "Preferences" impostatio su "Arduino Uno su COM22"? Magari mi funziona, se si ritrova gia' configurato...

che pc hai? caratteristiche? versone java? service pack di windows? che windows?

Usi per caso un sw di gestione del BT chiamato Bluesoleil?

Usi per caso un sw di gestione del BT chiamato Bluesoleil?

Che pa**e, e colpa sua ANCHE questa volta??? Ma che l'hanno inventato a fare???

Cmq ho WinXP Pro SP3 su un AMD-nonmiricordo dualcore 2.8 GHz 3 GB RAM.

Roba da pazzi, era colpa di bluesoleil per davvero! >:( Basta terminare i processi bluesoleil.exe e btntservice.exe e funziona tutto benissimo!

Grazie brainbooster, hai vinto una citazione nelle FAQ di Arduino! ;)

piccolo consiglio informatico: con quella configurazione e qualla ram windows 7 sarebbe un sistema operativo perfetto rispetto al vecchio xp

oppure una distro linux, per esempio ubuntu...