ARDUINO SERIAL PORT BUG

Hello everyone.

I work on a project in Arduino, and although is was working properly the previous days, I tried to reconnect the device to the computer again and I get this message:

“avrdude: ser_open(): can’t open device “\.\COM5”: The system cannot find the file specified.
Problem uploading to board. See http://www.arduino.cc/en/Guide/Troubleshooting#upload for suggestions.”

It can’t establish any connection with the board and therefore the device doesn’t work. It only responds for a few seconds and then just goes off. What can I do for this?

In the meantime we also tried to export data through processing, including COM5 in the processing code. Could this have affected the connection?

Thanks in advance

Yes, AFAIK a com port can only be connected to by one application at the time.

So if a background process is connected to COM5 you cannot connect it with AVRDUDE.
Some Bluetooth drivers seem to do their utter best to drive people nuts by connecting to any COM they find.

You might need to check your device manager (assuming you have Windows) and remove the port and then reconnect the Arduino.

Hope this helps...