Arduino Serial v2 - can no longer upload sketches

I bought an Arduino Serial v2 kit, that I assembled myself. I am very new at electronics, so I needed some hands-on experience.

I was unexpectedly successful: the board started, did not smoke, worked a bit, then I successfully uploaded the Blink Demo, then the Gradual-Blink Demo, then I made a consecutive turn-on-and-off on pins 5-13.

However yesterday I tried uploading a new sketch, that failed miserably!

My set-up: Laptop (Lenovo T500) + Ubuntu 9.04 Arduino Serial v2 + USB-Serial-Converter + Serial Extension Cable

I made some experiments using the avrdude and directly sending to the ttyUSB0 port. It seems I get an echo on the serial port, everything sent to the port I get back as response, which is kinda weird. I decided to measure the resistance between the serial TX and RX pins, and found it to be around 1.4-1.5 KOhms, but only when the board has power on :-/, which is obviously true when I am trying to upload a sketch.

Now... I am very new at this stuff... Please advise!