Arduino si riavvia se collegato con jack di alimentazione

Salve a tutti,

ho fatto un progetto con arduino che prevede di collegarlo su un pcb creato e stampato ad hoc.

Se utilizzo la presa USB collegata al computer oppure attacco la stessa a un caricatore per cellulare a 5V 2A nessun problema tutto funziona regolarmente.

Ora ho comprato degli alimentatori con jack di buona marca a 12V 3A (ho allegato una foto). Il problema è che dopo pochi minuti che sono collegati arduino inizia a riavviarsi o dare segni di malfunzionamento.

Ho provato su vari arduino e tutti danno lo stesso problema: usb funziona, jack no.

Secondo voi come posso risolvere? Devo utilizzare un alimentatore con caratteristiche differenti?

Grazie a tutti
Luca :smiley:

Manca di sapere COSA hai collegato ad Arduino perché ... potresti stare assorbendo troppa corrente ed il regolatore va in protezione.

Quando alimenti a 12V da Jack hai a disposizione meno corrente di quando alimenti via USB ...

Guglielmo

Ciao Guglielmo,

grazie della risposta.

Sono presenti un display 16x2 e 3 chip pcf8574 per leggere lo stato di alcuni input per lo più dei micro switch

è presente anche la ethernet shield

via USB uso un'alimentazione a 5V 2A
via jack uso un'alimentazione a 12V 3A

Grazie
Luca

NON conta ciò che tu usi per alimentare (purché sia in grado di dare almeno 1A) ...
... conta che dalla USB puoi assorbire fino a 500mA max. mentre se usi il connettore jack con un alimentatore da 12V ... più di 200/250 mA non puoi assorbire o il regolatore va in protezione termica.

Fai una prova, quando alimenti a 12V, metti un dito sul regolatore a 5V (con cautela, potrebbe essere molto caldo) e vedi ...

Guglielmo

Ciao Guglielmo,

ho fatto la prova e con l’alimentazione a 12V tramite jack il chip diventa bollente a livello di ustione!! (non ci avevo fatto caso)

Quindi tramite usb l’assorbimento massimo è di 500mA, mentre tramite jack l’assorbimento massimo è di 250mA.

A questo punto l’unica soluzione è alimentarlo tramite USB corretto?

Grazie
Luca

liuk88:
A questo punto l'unica soluzione è alimentarlo tramite USB corretto?

... hai più possibilità:

  1. la migliore, alimentare separatamente le cose che assorbono di più così che il regolatore non scaldi. L'importante è che il GND sia in comune

  2. provare ad alimentare sempre da Jack ma con un alimentatore da 7V DC ... la dissipazione termica dovrebbe essere decisamente inferiore

  3. fornire i 5V già regolati e stabilizzati dal pin 5V, scavalcando così il regolatore

  4. visto che ti funziona, alimentare dalla USB.

Guglielmo

Quando faccio queste cose, di solito uso un misto delle soluzioni 1 e 3 suggerite.

Alimento con alimentatore esterno 12 V e mi faccio i regolatori interni per avere le tensioni che servono al resto del sistema (soluzione 1) ed anche una linea 5 V che invio al 5 V (soluzione 2).

Questo mi consente, se decido di tenere il circuito, di passare ad uno "standalone" (implementi solo l'ATMEGA con un quarzo ed un paio di altri componenti e lo alimenti tramite i 5 V) senza toccare la sezione di alimentazione.

In generale, meno corrente fai passare internamente e meglio è.