Arduino sketch doesn't see Arduino board connected via USB

I plugged in my Arduino the other day and was able to upload new sketch programs to it. After modifying one of my servos (modified it for continuous rotation (see youtube video here: How to hack the TowerPro MG995 Servo for continuous rotation - YouTube)), plugging it in the Arduino and successfully running the program, the Arduino board will no longer connect to Sketch using the USB cable.

The other other thing I did was connect a 9V battery into the Vin and neighboring GND pins on the Arduino. When powered by the 9V battery, the Arduino seems to function perfectly.

But, when I disconnect the 9V battery and plug the Arduino back into the USB cable it powers up and begins running the last program. But, I can't upload new programs via Sketch. In Sketch under Tools -> Serial Ports menu, it's missing the USB tty ports.

I'm new at working with Arduinos and quite stumped. I've posted a picture of what I'm seeing below.


free upload pictures

P.S. - I should have added that I've tried two different servos. Tried using a different USB cable and different USB port on my computer. The results are the same, no USB TTY connection to the Arduino. =(

I found the following suggested fix, just in case someone sees this post and has a similar problem. I think it would work for me, but can't say for sure because I think my problem is a blown Arduino board.

I remember that I cross wired the control and power leads on my servo. After talking to my buddy who's a EE, he said it's likely it's blown. Also I connected the Arduino to a windows machine and another Mac. All three computers yield the same results, namely bubkis. So I just ordered a new Arduino. Hopefully it will work! :slight_smile:

My suspicion was confirmed. It was a blown Arduino board. Note to self, don't cross the streams (nor the control and power wires)!