Arduino software crashes on startup Mac

I just installed the newest software and it keeps crashing on startup

I found this in the crash report

Application Specific Information: *** Terminating app due to uncaught exception 'NSInvalidArgumentException', reason: '-[NSApplicationAWT setAutomaticCustomizeTouchBarMenuItemEnabled:]: unrecognized selector sent to instance 0x7fc87364a4b0' terminating with uncaught exception of type NSException abort() called

I'm using a 2015 macbook pro

It's solved now. i found another thread discussing this:

https://forum.arduino.cc/index.php?topic=587441.0

The problem was just with Arduino 1.8.8

Thanks for taking the time to post an update! I’m glad to hear you found a solution.

Also having this trouble on my Mac with 10.13.6 installed. Just tried 1.8.7 and same problem

Does anyone have an idea when a fix will be done??

The fix is already done. There just hasn't been a production release of the Arduino IDE since that time. When Arduino IDE 1.8.9 comes out, it will not have the bug. If you really need some feature of 1.8.8, but without the bug, you can use the Arduino IDE Hourly Build. However, be aware that the hourly build is primarily intended for beta testing and is not as thoroughly tested as the production IDE releases.

Hi, just delete Arduino folder in /Library/