Arduino STL library stopped working. Nothing helps!?

I get the following error message when ever i try use any STL library

C:\Arduino\libraries\ArduinoSTL-1.1.0\src\del_opvnt.cpp:25:58: error: ‘nothrow_t’ in namespace ‘std’ does not name a type

_UCXXEXPORT void operator delete(void* ptr, const std::nothrow_t& ) throw(){

^

exit status 1
C:\Arduino\libraries\ArduinoSTL-1.1.0\src\del_opvs.cpp:25:53: error: ‘std::size_t’ has not been declared

_UCXXEXPORT void operator delete(void * ptr, std::size_t) throw(){

https://forum.arduino.cc/index.php?topic=696369.0 ← This guy had the same problem and i tried to do
what he got told to do in the comments, but it didn’t work for me!

i switched from #include <ArduinoSTL.h> to #include “ArduinoSTL.h”

i switched back to 1.8.9 and from there to 1.8.13 and from there to 1.8.6

nothing works!?

i tried a different library: Arduino and the STL library (C++) - The Robotics Back-End

i had my arduino in Lenovo (D:) directory and then switched to Windows (C:) directory but that didn’t help

i had the libraries in: this pc / files / Arduino / libraries
then i tried: this pc / Windows (C:) / Arduino / libraries
then i tried having the library folder in the project file and then i moved all the files from the library folder to just being in the project folder.

Nothing still works!?