Arduino stürzt bei Relaisverwendung ab

Hallo,

ich bin an meinem ersten Arduino-Projekt und komme nicht mehr weiter. Meine elokronischen Grundkenntnisse sind leider nie mehr geworden und liegen schon einige Jahre zurück.

Mein Problem: Beim Ausschalten eines Relais (Türöffner) kommt es trotz Freilaufdiode zum regelmäßigen Absturz des Nanos.
Es ist kein kompletter Re-Boot, aber zumindest die Setuproutine wird ausgeführt. Die POWER-LED leuchtet jedoch ohne Unterbrechung weiter.

Meiner Vermutung nach gefallen dem Nano die trotz Diode auftretenden Spannungspitzen am VIN nicht. Falls ich da richtige liege: Wie kann ich dem Vorbeugen? Oder welche anderen Ursachen könnten noch verantwortlich sein?

Im Anhang ist meine Schaltung skizziert.

  • Spannungsquelle für Arduino und Türöffner ist die selbe mit 15V.
  • Strom des Türöffners sind 1450 mA

Das Forum hat mir schon beim ein oder anderen Problem geholfen. Würde mich freuen, wenn es eine Lösung für mein Problem gibt ohne die Platine umbauen zu müssen.

Besten Dank im Voraus & viele Grüße
Stefan

Unbenannt.PNG

Diese Art Störungen kommen häufig über die Betriebsspannung, denn wenn ca. 1,5A auf eine induktive Last (Türöffner) abgeschaltet werden, gibts einen ordentlichen EMV-"Hieb".

Ich würde folgende Dinge probieren:

a) auch parallel zum Türöffner eine Freilaufdiode (falls der mit Gleichspannung betrieben wird), oder wenigstens einen 100nF-Kondensator

b) [u]um[/u] alle möglichen Leitungen vom und zum Arduino und Türöffner sog. "Klappferrite" oder [u]in[/u] diese Leitungen Entstördrosseln

Wenn du die 15 Volt direkt auf den Arduino gibts, ist der schon ausserhalb der Spezifikation. Das bringt den Arduino schon an die Grenze.

Probleme bereiten auch gern offene Eingänge ohne Pullup-Widerstand.

stefan5232: - Spannungsquelle für Arduino und Türöffner ist die selbe mit 15V

ich würde mal verschiedene Stromquellen probieren. Wenns dann funzt, weisst du besser, wo du ansetzen musst.

Klingelanlagen sind schlechte Versorgungsspannungen. Sie sind meist unter Last stark am einbrechen.

Sollte zwar der regler ausgleichen, aber optimal ist das nicht. Hier könnte ein 1000µF Kondensator dir helfen das stabiler hinzubekommen. Auch ist der TÖ mit seinen 1,5A wie schon erwähnt ein guter EMV-Impuls. Haut schön durch, ein 100nF Kondensator hilft auch hier weiter.

Was mich etwas wundert: 90% der TÖ-Anlagen sind eigentlich AC. Deswegen hört man den TÖ brummen. DC brummt er nicht. Wenn du da AC hast, solltest du schnell abklemmen und erstmal einen Gleichrichter dazu basteln. Es reicht eine Diode und oben erwähnter Kondensator um dein AC zu stabiliseren. Aber vorsicht, 15V AC bringen dir fast 20V DC zustande. Das ist sehr grenzwertig für den Regler.