Arduino TX seems to be broken

The problem

My original Arduino Uno R3 has - for some reason - stopped returning Serial signals. The problem seems to be with the atmega16u since it failed the Loop-Back test. When i try to communicate/program via USB, RX lights up, but TX remains off.

The lead-up

The Arduino was working fine before. I used it to test a WS2812B LED strip (external supply, Arduino running via USB, common GND). At some point, the strip stalled which was fixed by multiple resets (it only worked for a few ms after the first two resets, but then continued as usual). Finally, I unplugged it from that test and connected it to a Dallas temperature sensor. At first, I just plugged the sensor into D13-D11, since it is only supposed to pull 4 mA. This, however, seemed to overload the chip (LED13 turned off), so I swiftly pulled it out again. One of those two events seems to have caused the problem.

What I tried so far

  • Flashing the atmega16u via Atmel FLIP (this hex-file) - No errors, all green
  • Burn the Bootloader with ArduinoISP (no errors)
  • Program the Arduino via ArduinoISP (no errors when programming, blink works fine)

What I found so far

  • Upon trying to upload using the onboard programmer, the RX will flash thrice with TX staying off (probably meaning the PC tries to establish comms, but gets no response)
  • The atmega16u is seen by the device manager in DFU mode and also by FLIP (so the USB side is working)
  • When uploading a program to Serial.write() every second, TX stays off. However -and I find this quite odd - while writing this, the Arduino was plugged in with this code running, and after five minutes or so, TX just lit up continuously
  • When in DFU mode, TX lights up, so it's no connection fault

I have run out of ideas now. Does anyone know what the problem could be?

To satisfy the forum rules, I am on Windows 10 18363, using Arduino 1.8.12. Both USB2 and USB3 were used while testing.

PS: The strange TX behavior after some time could not be replicated