Arduino und Bluetooth

Wenn ich mit dem PC einen USB-Bluetoothstick und mit dem Arduino einen Bluetooth Transceiver benutze, kann ich dann auf diesem Wege auch Sketche übertragen ?

Ich denk mal das es vom Prinzip gehen sollte. Das Problem ist, das du den Bluetooth Chip am Arduino irgendwie einstellen musst, also das die richtige Baud Geschwindigkeit und 8 N 1 eingestellt ist. Wenn Dein Bluetooth Chip diese Einstellungen speichern und nach dem Ausschalten behält dann sollte es gehen. Die richtige Geschwindigkeit weiß ich leider nicht würde es erst mal mit 38400 probieren

Gruß Ingo

Sketche damit zu übertragen sollte nur äußerst schwer und mit viel Programmierkenntnissen möglich sein.

Die Übertragung ist kein Problem (hatte es mal mit XBEE und Arduino20009 erfolgreich probiert); Das Problem ist, daß das nicht automatisch geht, da es zun Upload einen Reset braucht. Einen Finger im Richtigen moment am Restetknopf entscheidet über das erfolgreiche Uploaden. Grüße Uwe

Man kännte den Arduino doch durch einen DS1232 reseten !

Bleibt nur die Frage offen wie man dem Arduino mitteilt das nun ein Sketch kommt und dann durch den DS1232 den reset durchführen lässt ?

Damit habe ich mich gestern auch rumgeschlagen :)

Hier steht wie das mit dem Autoreset funktioniert (für Bluetooth Mate und wahrscheinlich auch andere mit BT Chip von Roving Networks): http://arduino.cc/forum/index.php/topic,65148.0.html

  • Kabel an die DTR-Leitung des BT-Moduls löten und mit einem 0.1uF Kondensator an Reset am Arduino anschließen
  • BT Modul konfigurieren (Geht auch mit dem Serial Monitor. Innerhalb von 60 Sekunden nach Anschalten im Serial Monitor mit "No line ending" $$$[Enter] eingeben, dann kommt man in den Config-Modus. Anschließend Line Ending auf ... bin mir nicht mehr ganz sicher, war glaube ich "Newline" stellen und Baudrate (SU, entsprechend dem benutzten Board, erste zwei Ziffern reichen. Also Duemilanove wäre 57 für 57,6 Mega2560 wäre 11 für 115,2) + Modus (S~) konfigurieren:
$$
SU,57
S~,3
---

Das geht wunderbar mit 'nem Duemilanove, aber der Mega 2560 will nicht immer so recht resetten. Bei gefühlten 100 Uploadversuchen hat es nur 3x geklappt, auch beim Öffnen des Serial Monitors wo er eigentlich resetten sollte tut sich nichts. Jemand 'ne Ahnung woran das liegen könnte? Vieleicht 'n anderen Kondensator?

Hallo sui,

welches BT Modul benutzt Du den ? Vielleicht ein Foto vorhanden ?