Arduino UNO and AVRISP

Hello;

I’m trying to upload sketches to an arduino UNO smd version using the AVRISP, but I’ve got the following error:

Binary sketch size: 1018 bytes (of a 32256 byte maximum)
C:\Documents and Settings\user\Desktop\arduino-0022\hardware/tools/avr/bin/avrdude -CC:\Documents and Settings\user\Desktop\arduino-0022\hardware/tools/avr/etc/avrdude.conf -v -v -v -v -patmega328p -cstk500v1 -P\.\COM9 -Uflash:w:C:\DOCUME~1\user\CONFIG~1\Temp\build896045470357879110.tmp\Blink.cpp.hex:i

avrdude: Version 5.4-arduino, compiled on Oct 11 2007 at 19:12:32
Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/

System wide configuration file is “C:\Documents and Settings\User\Desktop\arduino-0022\hardware/tools/avr/etc/avrdude.conf”

Using Port : \.\COM9
Using Programmer : stk500v1
avrdude: ser_open(): setting dtr
avrdude: Send: 0 [30] [20]
avrdude: Send: 0 [30] [20]
avrdude: Send: 0 [30] [20]
avrdude: Recv:
avrdude: stk500_getsync(): not in sync: resp=0x00
avrdude: Send: Q [51] [20]
avrdude: Recv:
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

avrdude done. Thank you.

I tried the troubleshooting guide, changed the COM port and baud rate on preferences.txt/boards.txt

Arduino is uploading sketches normaly when I use the USB port. But no luck with the AVRISP.

I’ve connected the AVRISP on the ICSP pins correctly, because AVR studio is working properly.

Any ideias ?

open your preference file and try changing upload.using=bootloader to upload.using=avrisp

Thanks for reply;

But I already did it.

When I try to upload, I get the white message "Binary sketch size: ... " then nothing happens. (The led on the arduino board don't blink 4 times)

+5V and GND rails are ok, I'm using arduino 022 and windows xp.

Looks like it could be a baud rate mismatch to me. I don't see a baud rate setting in the avrdude command.

Problem solved !

Just uploaded a new optiboot sent by westfw on this topic http://arduino.cc/forum/index.php/topic,64105.0.html

And it worked perfectly.