Arduino UNO and JY-MCU BT_BOARD V1.06

Hello Guys,

I've been trying to pair my JY-MCU BT_BOARD V1.06 Bluetooth module with my Android device and Macbook.

Everytime I scan to search for 'linvor' I find there are NO Devices available.
I have the module power through the 3.3V and GND pins on the Arduino Uno.

From my understanding all I need is power in order to be able to see it when I can for Bluetooth devices but like I said nothing comes up.

Any suggestion would be greatly appreciated. Could it be a faulty bluetooth module?

Connect the JY-MCU to 5v

I tried connecting it to both the 3.3V power source as well as the 5V source.
I still cannot find the bluetooth module when I scan with my phone.

Any other suggestions?

gusblan:
I tried connecting it to both the 3.3V power source as well as the 5V source.

Hopefully one at a time then?

I don't think there are any grey areas with this, it either works or it doesn't

  1. Forget the Mac. It will probably never work.

  2. If the module is ready to connect, the LED thereon will be flashing at 2Hz. In this event, you have done all you can do with Arduino and Bluetooth, and it is all down to the Android to get the connection. Note that, while my phone works perfectly, my Android tablet has never worked. The matter is made worse by my recently finding that it does work with a bluetooth keyboard.

  3. If there is no flashing LED, you still have a power problem.

  4. In the unlikely event that you have tried to connect and you now see a steady LED, you have actually succeeded without knowing it. Confirmation of a connection should be clear on the Android.

  5. I know you said you see no devices but, as a last shot, are you sure you have an HC-06? Only HC-06s report as LINVOR. HC-05s look the same but may just give a COM port number.

You might get some value from this link

http://homepages.ihug.com.au/~npyner/Arduino/GUIDE_2BT.pdf

I say might because I have never actually had this problem.