Arduino UNO and Mac Mountain Lion problem

Hello people:

I'm new in this forum...i switched from Windows to Mac (Macbook Pro with 10.8.2 OS X) some weeks ago and i'm having problems setting up my arduino board. I got an Arduino UNO with ATmega328 but i can't upload sketchs to my board...

First problem is that i can't find "Uno" on Tools>Board (i'm using the latest software) and i'm using instead "Arduino Duemilanove or Nano w/ATmega328. My arduino is on with the green and orange LEDs but i just can't upload anything. In Tools>Serial Port i selected /dev/tty.usbmodem1411 and when i try to upload something the orange LED and rx LED blink but nothing comes after...i got this message when trying to upload the Blink sketch:

Binary sketch size: 1008 bytes (of a 30720 byte maximum) avrdude: stk500_recv(): programmer is not responding avrdude: stk500_disable(): protocol error, expect=0x14, resp=0xe0

Thank you for helping me Greetings!

Try installing drivers again.

i already tried and nothing happens...i tried rebooting the mac too :(

Try changing the USB ports. Try other ports and see if it works.

Arduino doesn't work in any port :( one of the USB is connected to a 2.0 hub (Macbook USB are 3.0), i read Arduino could have problems with hubs so i used the other USB with no success. Thank you for helping me!

Edit: I tried using a 2.0 adapter in the free USB port and nothing changes

http://arduino.cc/en/Guide/MacOSX Did you use this tutorial?

Yes, i saw that guide while installing my board, i downloaded the software with those links but i can't get the "Arduino Uno" option and i have all the problems listed above

You don't have arduino Uno? Can you take a screen shot of the boards you have in the board list in arduino IDE?

okay, give me a second :) ill take some photos of the board too

Well the more the better. Pic of the board and the list of the devices in tools/boards.

Here they are :D

http://imageshack.us/photo/my-images/5/capturadepantalla201303t.png/ http://imageshack.us/photo/my-images/545/capturadepantalla201303em.png/ http://imageshack.us/photo/my-images/836/img6575b.jpg/ http://imageshack.us/photo/my-images/17/capturadepantalla201303l.png/ (i don't know what's the boot loader, but maybe it could help) http://imageshack.us/photo/my-images/839/capturadepantalla201303lu.png/

Bootloader is something that is written in the boot section or the first several bytes of the flash memory and is used to upload your sketches to the arduino via USB and Arduino IDE. By the way. It looks to me like it's a bit outdated. My arduino IDE has a lot more boards than yours. Try redownloading the Arduino IDE. http://arduino.googlecode.com/files/arduino-1.0.3-macosx.zip Also try this code

/* Blink Turns on an LED on for one second, then off for one second, repeatedly.

This example code is in the public domain. */

// Pin 13 has an LED connected on most Arduino boards. // give it a name: int led = 13;

// the setup routine runs once when you press reset: void setup() { // initialize the digital pin as an output. pinMode(led, OUTPUT); }

// the loop routine runs over and over again forever: void loop() { digitalWrite(led, HIGH); // turn the LED on (HIGH is the voltage level) delay(1000); // wait for a second digitalWrite(led, LOW); // turn the LED off by making the voltage LOW delay(1000); // wait for a second }

StereoBucket: It looks to me like it's a bit outdated.

Looks like version 0019 to me. @arockmez I would recommend version 1.0.3 unless you need support for the Due.

Thank you so much, ill try both and ill tell you what i got…i think the problem is my software because as i remember i downloaded it from spanish version of arduino website and when i download the software in the english website i get another version or at least a file with another name…ill try it and i think it will solve the problem because i realized spanish website is out of date. Thank so much! as the download finishes ill post something

Yeah looks like you got Beta version made for Due. Download that one in the link i gave you.

i downloaded it and everything is working like a charm!! thank you so much for helping me so quick and sorry for my dumbness of not being award that spanish version of arduino website is out of date. im so happy with my blinking led :D (Now, Arduino Uno option is available)

Dont forget to click the shinny green + button next to karma :grin:

clicked! :slight_smile:

Lets get ready to blink!