Arduino uno and Mac

Hi, I am new to this, and have fallen at the first hurdle. I bought an Uno, and am trying to upload to it from my mac laptop. It doesn't seem to recognise the serial port. HELP Please

Plug it in. Then open the network preference and click apply.

Thank you! But it treats it like a network connection, and asks me for information I don't have!

Yes it will don't put any information in. Click OK and then click apply. have you gone through this?:- and seen this:-

I follow all the instructions, and when I go to network, it shows Arduino Uno, and says it is configured, but not connected. I press connect, and then it comes back telling me there is a modem problem.... I am connected to the internet via wifi....

I have so much riding on this, I am starting to feel slightly desperate!

it shows Arduino Uno, and says it is configured, but not connected


I press connect,

No don't do that just click apply. Then run the arduino environment and select the top port from the tools menu. Then select the UNO from the board sub menu. It will then allow you to down load stuff to it.

I am connected to the internet via wifi

No odds either way.

I am at work at the moment so I don't have access to my mac, but if you can wait 4 hours I can talk you through it if you want.

I would love that. thank you. I even took my mac to the apple shop today, to check there was nothing wrong with the USB connections!

I shall keep trying....

actually, the problem I am having, seems to be with the macbook pro. I tried it on the computer at home, and as you said, it just worked. this gives me a bit of a dilemma, because I really need it to work off a laptop, and mine is a macbook pro.

Have even tried it with an independent 9V power supply, and that doesn't seem to help. I am out of ideas!

On the macbook, it doesn't let me just accept the arduino uno in the USB port. Deep sigh .... :(

Well I am running a Mac book pro here (at home now) with 10.6.4 so I am not sure what is wrong with your system, sorry.

Thanks anyway Mike.

Mike, the Uno definitely has problems through a hub under 10.6.4. It also wants to add a new connection for every port you plug the thing into, which is sub-optimal. See my experiences here:

Thanks for the posts, guys. I updated the instructions to clarify about the network configuration options, and added a troubleshooting suggestion about not using a hub.

when I go into my network preferences it says "arduino uno is configured, but is not connected"

when I go into my network preferences it says "arduino uno is configured, but is not connected

OSX sees the UNO as a modem. Nothing in the network prefereces matter, except that it shows up as a device. "connected" in this sense refers to a modem bring connected to anther modem. NOT that the "Arduino is connected."

But then why isnt it uploading anything. my tx and rx flash but I get a avrude error

try using an external 9v power supply when uploading up till today i have been having the same type of problem. Let me know if it helps ya..

tired using a dc adapter while uploading and sitll got the same issue. Im really considering just sending it back

bubba5656: which version of the Arduino software are you using? What board do you have selected? What error do you get? here is my info. sounds like the op and I have close to the same problem

I have searched the internet for a week now and cant find the solution or even someone with the exact same problem as me and it is kind getting ridiculous is there anyone at arduino that can atleast tell me if it is my laptop or the arduino uno that is causing the issue