Arduino UNO and Nano not recognized by Arduino IDE

Hi! I have been using my UNO and Nano for about a year now and they worked perfectly fine until now. After I have updated my Arduino IDE from 1.8.1 to 1.8.5, the IDE no longer recognize my UNO and Nano when I plug them in, the port tab is simply greyed out and when opening Serial Monitor it displays

Arduino: 1.8.1 (Windows 10), Board: "Arduino Pro or Pro Mini, ATmega328 (5V, 16 MHz)"

Board at COM5 is not available

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.

. However, my Arduino Pro Mini can still be recognized when connected via an FTDI programmer. In Device Manger, the UNO and Nano are recognized by Windows and is shown as a COM Port number with the description as FTDI. I have tried to revert to version 1.8.1 but it makes no difference. I also tried forcing the IDE to choose the COM port inserted by using preference.txt, but it has no use. I tried to use the motherboard USB port instead of the USB hub but nothing changed. I am using Windows 10. This is the first time that I have experienced such problem throughout the past year. I have searched through many forums and guides but none of them worked. I hope that someone here can help me.

Please turn on VERBOSE as suggested in the error msg. and post the complete error.
Also AVOID USB 3.0 ports and cables as they are known to cause issues.

Please check DEVICE MANAGER too for any items that have issues and fix those first.

Turn off any additional security just to test as well as some antivirus etc has been seen to cause issues.

Be aware that some other programs can also intercept the COM ports such as phone sync software or other IDE's etc so make sure nothing else is blocking the port.

Arduino: 1.8.1 (Windows 10), Board: "Arduino Pro or Pro Mini, ATmega328 (5V, 16 MHz)"

Board at COM5 is not available

I have enabled verbose and this is the full message. I have also checked the Device Manager and my Nano is displayed as “USB-Serial CH340(COM7)”, but the IDE doesn’t recognize it. Could this be an issue of me updating the IDE to 1.8.5, then because of it still not working reverting it back to 1.8.1? I have had it working with my USB hub in USB3.0 before, but nonetheless, I changed to an USB2.0 port as you suggested. I have no antivirus installed except Windows defender but it should not affect the IDE anyways. I also don’t use any other phone sync software and no other software were changed or updated except the IDE. But I am still not sure if it was caused by the new IDE. If you need any additional info, I can provide it too. Thanks in advance. P.S. photo of Device Manager and IDE attached.

You have to select COM 7 in the IDE and NOT com 5 for the clone NANO.

Each board will present itself as a different COM port and you have to select both the correct board AND the correct com port to match that board. That is the drawback of most clones. They simply present as a COM port with no indication as to the type of board.

Also stick with USB 2.0 where possible to avoid future issues. It sound like yours may be fine but it is a tip worth remembering.

I presume seeing as it lists the port as "USB-Serial CH340" you have the correct drivers installed from HERE which is the official source.

Thinking you just need to correctly match each board to the correct port to get past this issue.

I have over 14 boards live inc. clones and it can be a PITA at times.

I have switched to Arduino Nano in board selection tab, however, the port tab is still greyed out. I am sure that Windows recognize my Nano since it is displayed in Device Manager. I can do nothing since the port tab does not allow me to select any COM port nor display any for me. I understand that I have to select the corresponding port but I cannot and that is the problem. Could there be anything that I may do in this situation? It is such a strange problem:(

Have you recently changed or upgraded the IDE ?

Are you 100% sure it is the NANO you are picking up in device manager.
To test open device manager and expand the COM & LPT tab.
Unplug te NANO and watch which port dissapears..
Wait a few moments then plug it back in to see which port appears.

If there is anything odd then uninstall the drivers you used and install the ones I linked to above but do so with "DRIVER ENFORCEMENT" turned OFF (you can google that) and do so as "ADMINISTRATOR" (you can google run as administrator too.)

As I mentioned in my first post, I did update the IDE from 1.8.1 to 1.8.5, and that's what I suspected causing such problem. However, when I reverted back to 1.8.1, this problem remained. I am not sure if it was a back in 1.8.5 or something else odd that happened around the time when I updated the IDE a week ago. I have tried plugging and unpluging the Nano and even switching USB port. I can see that the COM port number did change when I swithch to another USB port. After this problem arised, I searched all over Google and found a video suggesting to install the WCH driver instead of the FTDI driver, and it linked to the same link as yours. I installed the driver and in Device Manger I can see that in details tab, the manufacturer changed from FTDI to WCH. But the IDE did not respond to this change. I so regret updating to 1.8.5 since it was fine before.