Arduino Uno appears on ports but Mega doesn't. MacOS Sierra, Arduino 1.8.1

I have an Arduino UNO and multiple MEGA 2560's here and am running the Arduino IDE (1.8.1) on macOS Sierra. The UNO works fine and connects with the IDE, however all of the MEGA's don't work and fail to appear in the ports of the software.

In system information on the mac, the UNO appears as 'Communication Device', with the manufacturer of Arduino and a Product ID of '0x0043'.

The MEGA's however appear as 'USB 2.0-Serial', with no manufacturer and a Product ID of '0x7523'.

Any advice on how I can connect the MEGA would be great!

What USB/Serial chip do they have on them? Atmega16U2, CH340, something else?

I suspect that the megas are clones using ch340 chips for the usb; do a search for ch340 in combination with mac in the searchbox in the top


I_clarke needs to check that ch340 drivers are installed then. A link to them has been posted multiple times.

Thanks guys, so I had tried installing the ch340 drivers before, hadn't worked however after a bit more research there was an updated copy for macOS Sierra, that has worked. Thanks all.

Glad to hear that worked for you. I'm still seeking a solution for the 'genuine' Arduino boards with the AVR as the USB-serial. Pretty much MacOS seems to flip a coin when deciding whether the Arduino will get a serial device and/or whether the Arduino IDE will see it. After reading through all the silly workarounds that only work about half the time (which is where I am without any workaround), I've given up on Arduino on MacOS, and I just boot to Windows whenever I want to do Arduino stuff. Wish I didn't have to do that, but it seems that's where things are. :-/