Arduino UNO ATmega328P ATmega16U2 not detected on OSX 10.7 (Lion)

Hi All,

I have search around for 2 days figuring out why this is not detected on OSX 10.7.

Situation will be: I have already have a board from freetronics using mini USB as connector, and this one found and runs alright on the mac. Recently bought another one (Unknown brand - it's really difficult to find Arduino-Arduino here), and my mac has failed to detect it, not even on the system list. Tried it on 2 macs with the same operating system without any luck. Tried it on PC, detected and upload alright.

My conclusion: This is not the board or cable problem. I would reprogram using DFU but not sure if this is related at all.

I have tried nstalling FTDI driver - not working

Anyone have any experience on this before? :~ :(

Please help...

Additional note: I have got this message from the console when I plug in the Arduino.

19/05/14 7:19:46.000 PM kernel: USBF: 20883.941 AppleUSBOHCI[0xffffff800aebc000]::SuspendUSBBus Processing WDH before suspending 19/05/14 7:19:47.232 PM hidd: MultitouchHID: device bootloaded 19/05/14 7:19:47.000 PM kernel: AppleUSBMultitouchDriver::message - kIOUSBMessagePortHasBeenReset. 19/05/14 7:19:47.000 PM kernel: AppleUSBMultitouchDriver::checkStatus - received Status Packet, Payload 2: device was reinitialized